Closed Bug 1566423 Opened 2 years ago Closed 2 years ago

Android 7.0 TV mochitests run against the Fennec APK instead of TestRunnerActivity

Categories

(Firefox Build System :: Task Configuration, defect)

defect
Not set
normal

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: robwu, Assigned: gbrown)

References

Details

Attachments

(1 file)

According to the first comment at bug 1563281, Android 7.0 tests generally run with GeckoView.

Apparently, this is not the case for TV tests, and several days were wasted on debugging a try-only test failure (because the issue happened with Fennec only, and the expectation was that the tests only ran on GeckoView).
The lack of TV test coverage reduces the likelihood of catching common causes for intermittent failures at an early stage, so hopefully TV is going to be enabled for GeckoView soon.

Example of TV with unexpected results: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=256704266&revision=badc5136d3cfa1c866713fd1648109f7ad664216

Example of mochitest that runs as expected: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=256704268&revision=badc5136d3cfa1c866713fd1648109f7ad664216

I think that something needs to be added at https://searchfox.org/mozilla-central/rev/07f7390618692fa4f2a674a96b9b677df3a13450/taskcluster/ci/test/misc.yml#78 , but you probably know better. Could you take a look?

Flags: needinfo?(gbrown)
Duplicate of this bug: 1558185
Depends on: 1553225
Flags: needinfo?(gbrown)

It is easy to change Android 7.0 TV to run against geckoview, but Android 7.0 xpcshell still runs against fennec, and TV verifies xpcshell tests as well as mochitest and reftest. Let's see if we can move bug 1553225 along soon so that all of Android 7.0 can run against geckoview.

See Also: → 1563277
Assignee: nobody → gbrown

As soon as xpcshell is switched over to geckoview, we can do the same for android TV.

Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43f551ed9167
Run Android 7.0 TV against geckoview; r=jmaher
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.