Insert in HTML compose does nothing, trunk build only

VERIFIED DUPLICATE of bug 156685

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 156685
16 years ago
10 years ago

People

(Reporter: esther, Assigned: varada)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using Trunk build 20020711 on linux (still need to check othe platforms), HTML
compose Insert doesn't work for all 5 of the Insert options.  This worked on the
7-8 trunk build.  Editor Insert works, just mail compose Insert is broken

1. Launch Mail
2. Open an HTML compose window
3. Try to Insert any of the 5 Insert options from menu bar or formatting bar.

Result: Nothing happens
Expected: Insert to work
-->varada
Assignee: ducarroz → varada
Summary: Insert in HTML compose does nothing, trunk build only → Insert in HTML compose does nothing, trunk build only
Starting the compose window:

Warning: reference to undefined property
Components.classes['@mozilla.org/ldapprefs-service;1']
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 108

Error: redeclaration of const MOZ_HELP_URI
Source File: chrome://help/content/contextHelp.js
Line: 1


Clicking on message part:

Error: gEditor has no properties
Source File: chrome://editor/content/editor.js
Line: 191

*4


Trying the insert commands:

Error: gEditor has no properties
Source File: chrome://editor/content/editor.js
Line: 191

*1 each
(Reporter)

Comment 3

16 years ago
Probably a dup of bug 156685.
dumpage:

Starting compose window:

ERROR: Cannot get the LDAP service
TypeError: Components.classes['@mozilla.org/ldapprefs-service;1'] has no properties
[nsIMsgIdentity: id1],[nsIMsgIdentity: id2],[nsIMsgIdentity:
id4],[nsIMsgIdentity: id5],[nsIMsgIdentity: id6],[nsIMsgIdentity:
id7],[nsIMsgIdentity: id3],[nsIMsgIdentity: id8],[nsIMsgIdentity: id9]
RemoveInapplicableUIElements called too early
----------------------
PrepareDocumentForEditing
no body tag found?!


Clicking on message part:

An error occurred updating the cmd_smiley command
An error occurred updating the cmd_advancedProperties command
An error occurred updating the cmd_removeLinks command
An error occurred updating the cmd_removeNamedAnchors command


Trying the insert commands on the toolbar:

An error occurred executing the cmd_link command
An error occurred executing the cmd_anchor command
An error occurred executing the cmd_image command
An error occurred executing the cmd_hline command
An error occurred executing the cmd_table command

Comment 5

16 years ago
*** Bug 157138 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
I do not see this with today's release nor my debug build. Do you still 
continue to see this?
worksforme linux trunk cvs 2002-07-30.

Comment 8

16 years ago
resolving as dupe per comment 3

*** This bug has been marked as a duplicate of 156685 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
*** Bug 156972 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.