Closed Bug 1569989 Opened 6 months ago Closed 5 months ago

"show password" option not available for generated passwords auto-saved doorhanger

Categories

(Toolkit :: Password Manager, defect, P2)

70 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: aflorinescu, Assigned: MattN)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Whiteboard: [passwords:generation] [skyline])

Attachments

(1 file)

[Steps:]
  1. New profile - preferably.
  2. Open any login form.
  3. Password field / context menu/ Fill Password / Use a Securely Generated password.
  4. In the address bar press on the key icon that opens password message pannel.
[Actual Result:]

The show password checkbox is missing.

[Expected Result:]

The show password checkbox should be available for the auto-saved generated password as specified in https://mozilla.invisionapp.com/share/6XR9ZKTJ8GK#/screens/368486346.

[Note:]

Arguably, this behavior would be expected if the doorhanger is dismissed by user action (see bug 1178855), but for this particular scenario, the doorhanger is defaulted as dismissed.

Duplicate of this bug: 1569302
Priority: -- → P2
Flags: qe-verify+

I think there is going to be some complication here as we also don't want to show the toggle if the password in the prompt is one that was already in storage e.g. if we are only adding a username… The reason is that we don't want someone who autofills a password having such trivial access to see the submitted password in the doorhanger after submission. Differentiating an auto-saved generated password with no username from a long-time saved submitted password without a username where one was added in the form will probably be necessary. Maybe looking at timeCreated is good enough?

I'll look into this.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

If the login is older than 2 minutes, don't allow revealing the password in the doorhanger.

Blocks: 1571647
Attachment #9082640 - Attachment description: Bug 1569989 - Show the password visibility toggle in some dismissed-by-default doorhangers. → Bug 1569989 - Show the password visibility toggle in some dismissed-by-default doorhangers. r=sfoster
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/8e3bef2e7d77
Show the password visibility toggle in some dismissed-by-default doorhangers. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Depends on: 1576199

Reproduced the issue on affecte Nightly 70 (2019-07-30) on Windows 10 x64.

This is verified- fixed on the latest Nightly 71.0a1 (2019-09-09) (64-bit) and Beta 70.0b4 (64-bit).
The "show password" option will be available in the doorhanger and will also disappear after dismissing the doorhanger as per expected scenario mentioned in Bug 1178855.

However, please note that the specific scenario described in Bug 1576199 still affects the correct functionality of this option (show password is available two times in the dismissed door-hanger - when the scenario is used).

Status: RESOLVED → VERIFIED
No longer depends on: 1576199
Flags: qe-verify+
Depends on: 1576199
Depends on: 1583558
You need to log in before you can comment on or make changes to this bug.