Closed Bug 1570792 Opened 1 year ago Closed 11 months ago

Surface enable/disable action from meatball menu

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: amyt, Assigned: mstriemer)

References

Details

Attachments

(2 files)

As the next iteration of the meatball (3-dot) menu, let's surface the three most commonly used actions so they can be accessed with one click.

For extensions and themes under the Enabled header, surface "Disable" and "Delete" to the left of the meatball menu.

For extensions and themes under the Disabled header, surface "Enable" and "Delete" to the left of the meatball menu.

For default Firefox themes, surface either "Disable" or "Enable", but not "Delete".

This should be implemented in both the compact and expanded views of the extension card.

Flags: needinfo?(emanuela)
Priority: -- → P1
Duplicate of this bug: 1565057

Is anyone working on this? Seems easy enough. Gimme a starting point and I'll look into it.

Yeah, this is already in progress.

Assignee: nobody → mstriemer
Flags: needinfo?(emanuela)
Summary: Surface enable/disable and delete actions from meatball menu → Surface enable/disable action from meatball menu
See Also: → 1575905
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf2f28971e64
Toggle extension enabled state on the card r=rpl,fluent-reviewers,Gijs
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74f97d22bea2
Backed out 4 changesets (bug 1570792, bug 1593358, bug 1575905) for causing bug 1593402 to near permafail. CLOSED TREE
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/645ddd53d804
Toggle extension enabled state on the card r=rpl,fluent-reviewers,Gijs
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Depends on: 1598901

Verified the fix on the latest Nightly (72.0a1/20191126212708) under Windows 10 Pro 64-bit and MacOS Catalina 10.15.

Comparing with Comment 1, the following were observed:

For extensions and themes under the Enabled header:

  • Extensions: a switch to perform the enabling/disabling is present to the left of the meatball menu. As the extensions is enabled, the switch is blue. The “Remove” option is still under the meatball menu and is not exposed on the add-on card.
    This is true for both the compact and the expanded views of the extension card.
  • Themes: a button with a “Disable” string is present to the left of the meatball menu, as the theme is enabled. The “Remove” option is still under the meatball menu and is not exposed on the theme card.
    This is true for both the compact and the expanded views of the theme card.

For extensions and themes under the Disabled header:

  • Extensions: a switch to perform the enabling/disabling is present to the left of the meatball menu. As the extensions is disabled, the switch is grey. The “Remove” option is still under the meatball menu and is not exposed on the add-on card.
    This is true for both the compact and the expanded views of the extension card.
  • Themes: a button with a “Enable” string is present to the left of the meatball menu, as the theme is disabled. The “Remove” option is still under the meatball menu and is not exposed on the theme card.
    This is true for both the compact and the expanded views of the theme card.

For default Firefox themes:

The default Firefox Theme (the theme with the operating system color scheme) has no buttons present to the left of the meatball menu for the compact view of the theme card. The theme is automatically enabled when other themes are disabled. The expanded view of the theme card has no buttons or switches present whatsoever.

For the Dark and Light default themes, the same behavior as mentioned above for enabled/disabled themes is true.

Please see the attached screenshot for further details.

Before closing this as Verified Fixed, can you please confirm that this is the intended behavior?

Flags: needinfo?(mstriemer)

This sounds right to me, thanks!

Flags: needinfo?(mstriemer)

Hello,

Based on the above comment and having verified the dependency (https://bugzilla.mozilla.org/show_bug.cgi?id=1598901), closing the issue as Verified Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.