Closed Bug 1571552 Opened 3 years ago Closed 1 year ago

Day view in calendar tab always defaults to 00:00

Categories

(Calendar :: Calendar Frontend, defect)

Lightning 68
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jorgk-bmo, Unassigned)

References

Details

(Keywords: regression)

This was found in beta testing.

Click on Multiweek and then on Day. Day always seems to start at 00:00. Beta tester also reported that for the Week view, but I don't see that.

Seems partly intermittent.

Flags: needinfo?(geoff)

Not sure why it would be 00:00, but it appears that the scroll position is reset at every view switch.

I also find that the views load the value of calendar.view.daystarthour and calendar.view.dayendhour only at start-up and don't respond to changes. (At least when it comes to scroll position, the background colour does respond.) But that's always been the case.

Flags: needinfo?(geoff)

Paul, can you investigate? I suspect it's something to do with onResize in calendar-multiday-base-view.js. I'm not sure if that's changed or if we're now calling it more than we used to.

Flags: needinfo?(paul)
Keywords: regression

Hm, just took a look and I wasn't able to reproduce the problem. When I switch away from the day view (or the week view) and then switch back, the scroll position for the day (or week) view stays the same. I'm on Ubuntu, if that makes a difference.

I'm working on checking on my windows setup. The build will take some time.

Flags: needinfo?(paul)

Couldn't reproduce this on Windows 10 either. I tried a fresh profile on Ubuntu and still didn't reproduce it there either.

I found the same issue when testing Thunderbird 68.0-candidates/build4/ and have reported it in bug 1574504 (which I had initially opened for TB 69.0b2).

Duplicate of this bug: 1574504
Blocks: tb68found

(In reply to Eckard Berberich from comment #5)

I found the same issue when testing Thunderbird 68.0-candidates/build4/ and have reported it in bug 1574504 (which I had initially opened for TB 69.0b2).

Still seeing in betas?

Flags: needinfo?(de.berberich)

No, the bug is fixed in the actual beta 77.

Flags: needinfo?(de.berberich)
Summary: Day view in calendar tab always defaults to 00:00 in TB 69 beta → Day view in calendar tab always defaults to 00:00
Version: Lightning 69 → Lightning 68
Duplicate of this bug: 1617587
Duplicate of this bug: 1612736
Duplicate of this bug: 1646889

This seems to be fixed since before Tb 78 (also see comment#8). Resolving as WORKSFORME.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.