Closed Bug 1571663 Opened 4 months ago Closed 4 months ago

Attachment area too high when there is more than one attachment

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: jorgk-bmo, Assigned: aleca)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image too high.png

I've just noticed this now in my TB 68 ESR pre-release. If there's more than one attachment, like two attachments, the area is too high, see screenshot. Should be the same height as for one attachment which works OK.

Flags: needinfo?(alessandro)

Same issue in Daily.

In addition to this, there is a regression on win only (maybe mac too), where a detached/external attachment does not appear like a link, the .text-link color is overridden. I think it's due to .text-link no longer being added to the child node post de-xbl. This is an important visual.

Summary: Attachment area too heigh when there is more than one attachment → Attachment area too high when there is more than one attachment

So, apparently the richlistbox automatically increases its height to show 2 richlistitems, ignoring the orient="horizontal" attribute.
Wrapping that element around an hbox seems to do the trick.
Can you guys help me thoroughly test this to be sure we're not introducing other regressions or UI issues?

Richard, can you help for macos testing?

Flags: needinfo?(alessandro)
Attachment #9083479 - Flags: ui-review?(richard.marti)
Attachment #9083479 - Flags: review?(jorgk)

(In reply to alta88 from comment #2)

In addition to this, there is a regression on win only (maybe mac too), where a detached/external attachment does not appear like a link, the .text-link color is overridden. I think it's due to .text-link no longer being added to the child node post de-xbl. This is an important visual.

I don't have Windows, currently testing on mac.
Can you open a dedicated bug with a screenshot and assign it to me, please?
Thanks

Comment on attachment 9083479 [details] [diff] [review]
1571663-attachment-area.patch

Seems to work. I'm no expert with this stuff (and Richard is peer).
Attachment #9083479 - Flags: ui-review?(richard.marti)
Attachment #9083479 - Flags: review?(richard.marti)
Attachment #9083479 - Flags: review?(jorgk)
Attachment #9083479 - Flags: feedback+
Attached image link-when-hovered.png

Well, there is an underline shown for a link when hovered. If not hovered, it looks like the others.

Target Milestone: --- → Thunderbird 70.0
Comment on attachment 9083479 [details] [diff] [review]
1571663-attachment-area.patch

Let's assume this passes review ;-)
Attachment #9083479 - Flags: approval-comm-esr68+
Attachment #9083479 - Flags: approval-comm-beta+
Comment on attachment 9083479 [details] [diff] [review]
1571663-attachment-area.patch

Thanks, Alessandro.
Attachment #9083479 - Flags: review?(richard.marti) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5d12044b6279
fix height of attachment pane. r=Paenglab DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Blocks: 1572106
No longer blocks: 1572106
You need to log in before you can comment on or make changes to this bug.