Closed Bug 1571700 Opened 2 years ago Closed 2 years ago

The Fill Password/Login context menu shows on about: pages

Categories

(Toolkit :: Password Manager, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: srosu, Assigned: sfoster)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [passwords:generation] [skyline])

Attachments

(2 files)

[Notes]:

  • The "Use a Securely Generated Password" context menu option is available on "about:logins" page, only after a password was generated on other websites. However, after the option is available on "about:logins" page, the option doesn't work if it's used, no password is generated.-

[Affected versions]:

  • Firefox latest Nightly 70.0a1 (2019-08-05) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 18.04 x64

[Steps to reproduce]:

  1. Open the browser and navigate to the "about:logins" page.
  2. Click on the “Create New Login” button.
  3. Right click on the password field and hover the "Fill Password" option.
  4. Observe the sub-context menu.

[Expected result]:

  • The "Use a Securely Generated Password" option from the sub-context menu of the password field is displayed.

[Actual result]:

  • The "Use a Securely Generated Password" option from the sub-context menu of the password field is not displayed.

[Regression]

  • The issue is not reproducible with older Nightly 70.0a1 builds. Considering this, using mozregression tool I have found the issue that broke this in the latest Nightly build. Here are the results:
  • Pushlog: https://tinyurl.com/y6nfgy5n
  • Last good revision: f4fb2058c3e94df4261893654e4f72e04ca5793c
  • First bad revision: 06f72b9d9d144e098cc74d8cedb71e460c3fabee

From this pushlog it seems that bug 1569093 introduced this behavior.

[Additional notes]:

  • Attached a screen recording with the issue.

It wasn't really required to work on about:logins but I guess an error is getting thrown due to about:logins being special. The Browser Console would show it probably. Marking as P2 since we should fix it since there is an error and double separator but it's not a blocker IMO.

Priority: -- → P2
Whiteboard: [passwords:management] [skyline] → [passwords:generation] [skyline]
Summary: The "Use a Securely Generated Password" context menu option is no longer displayed on the password field from “about:logins” if it was never used on other websites → The "Use a Securely Generated Password" context menu option is no longer displayed on the password field from "about:logins" if it was never used on other websites
Blocks: 1550171
Summary: The "Use a Securely Generated Password" context menu option is no longer displayed on the password field from "about:logins" if it was never used on other websites → The Fill Password/Login context menu shows on about: pages
Duplicate of this bug: 1572445
Assignee: nobody → sfoster
Status: NEW → ASSIGNED

I'm planning on not showing the fill-login* elements for all about: pages. Or is that over-zealous?
I.e. adding a !documentURI.schemeIs("about") condition to https://searchfox.org/mozilla-central/rev/03853a6e87c4a9405fce1de49e5d03b9e7a7a274/browser/base/content/nsContextMenu.js#987

  • Skip showing the password manager items in the context menu from an about: page
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f0f0bb22d79
Don't show fill logins context menu item in about: pages. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue on the latest Nightly 70.0a1 (2019-08-2) (64-bit) on Windows 7 64, MacOS 10.14 and Ubuntu 16.04.

  • The Fill Password/Login context menu is no longer available on "about:*" pages.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.