Closed Bug 1572544 Opened 1 year ago Closed 1 month ago

Partition our HTTP connection pool per the top-level document's origin

Categories

(Core :: Networking: HTTP, task, P2)

task

Tracking

()

RESOLVED DUPLICATE of bug 1639154

People

(Reporter: ehsan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

We need to do this for parity with what Chrome is implementing with their HTTP Cache paritioning (see the second message in https://groups.google.com/a/chromium.org/forum/m/#!msg/blink-dev/6KKXv1PqPZ0/3_1nYzrBBAAJ).

This mostly amounts to what we double-key for third-party trackers with ETP turned on in bug 1535697 through calling nsHttpConnectionInfo::SetIsolated() here: https://searchfox.org/mozilla-central/rev/e0b0c38ee83f99d3cf868bad525ace4a395039f1/netwerk/protocol/http/nsHttpChannel.cpp#640. Note that we currently have two places where we don't do this, one is when making speculative connections (https://searchfox.org/mozilla-central/rev/e0b0c38ee83f99d3cf868bad525ace4a395039f1/netwerk/protocol/http/nsHttpHandler.cpp#2455) and one is for Alt-Svc (https://searchfox.org/mozilla-central/rev/e0b0c38ee83f99d3cf868bad525ace4a395039f1/netwerk/protocol/http/AlternateServices.cpp#319). For the latter bug 1569224 is on file and I've attached a patch there which would need minimal adjustments here.

Priority: -- → P2
Whiteboard: [necko-triaged]
Flags: needinfo?(dd.mozilla)
Blocks: 1590107
Flags: needinfo?(dd.mozilla)

This is fixed now, no?

Flags: needinfo?(tihuang)

Yes, I think we have fixed this with the network state paritioning.

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(tihuang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1639154
You need to log in before you can comment on or make changes to this bug.