Closed Bug 1573631 Opened 4 months ago Closed 3 months ago

[css-text-decor-4] Let `text-decoration-skip-ink`, `text-decoration-thickness`, and `text-underline-offset` ride the trains to release

Categories

(Core :: Layout: Text and Fonts, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
relnote-firefox --- 70+
firefox70 + fixed
firefox71 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(5 keywords)

Attachments

(1 file)

I'm filing this bug on letting text-decoration-skip-ink ride the trains to release (i.e. setting layout.css.text-decoration-skip-ink.enabled to true unconditionally)

For any issues that definitely need to be fixed before we ship, we should mark the issue as blocking this bug.

Note also that we'll be enabling the pref in Nightly (at least) very soon in bug 1572800.

Per bug 1572800 comment 3, we should probably enable all three new text-decoration properties as a bundle.
--> updating summary & dependencies. (And adding bug 1574222 as dependency since we need to fix that before letting text-decoration-thickness hit release.)

Depends on: 1573725, 1573724, 1574222
Summary: [css-text-decor-4] Let `text-decoration-skip-ink` ride the trains to release → [css-text-decor-4] Let `text-decoration-skip-ink`, `text-decoration-thickness`, and `text-underline-offset` ride the trains to release
Depends on: 1574392
Depends on: 1575338
No longer depends on: 1574222
Depends on: 1574222

Looks like this is something you're aiming to ship in 70 - can you suggest a release note if you think one is a good idea?

relnote-firefox: --- → ?
Flags: needinfo?(dholbert)

Thanks! Yes, a release note would be a good idea.

Something like the following would be good:

  • Firefox now supports the CSS properties "text-decoration-thickness" and "text-underline-offset", which let web developers control the position and size of text decoration lines.
  • Firefox now supports the CSS property "text-decoration-skip-ink", which (by default) makes underlines and overlines skip over any text that they intersect, to improve readability.
Flags: needinfo?(dholbert)

[Tracking Requested - why for this release]:
Planning on shipping these features as part of Firefox 70 (pending bug 1574222 making it there - that's the last minor defect that we're aware of).
They're already enabled through "early beta" (so 70beta users already have these , and this bug here is aimed at removing that restriction.

Assignee: nobody → dholbert
Status: NEW → ASSIGNED

Tracking since we aim to ship this in 70.

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3f08b7d13ccc
Let "text-decoration-skip-ink", "text-decoration-thickness", and "text-underline-offset" ride the trains to release. r=jfkthame
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

I posted an intent-to-ship to dev-platform: https://groups.google.com/forum/#!topic/mozilla.dev.platform/2h1Nlx4_WIU

Toggling needinfo to remind me to do an uplift request.

Flags: needinfo?(dholbert)

Comment on attachment 9091533 [details]
Bug 1573631: Let "text-decoration-skip-ink", "text-decoration-thickness", and "text-underline-offset" ride the trains to release. r?jfkthame

Beta/Release Uplift Approval Request

  • User impact if declined: These new text decoration features would automatically become disabled after we exit the "early beta" period (and they wouldn't ship until Firefox 71), even though we think they're ready now.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1574222 (which has its own beta-uplift request)
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch just touches pref guards, so that the configuration that we've already been testing in "early beta" (these features being enabled) will persist through the rest of the beta cycle and into release.
  • String changes made/needed: None.
Flags: needinfo?(dholbert)
Attachment #9091533 - Flags: approval-mozilla-beta?

Comment on attachment 9091533 [details]
Bug 1573631: Let "text-decoration-skip-ink", "text-decoration-thickness", and "text-underline-offset" ride the trains to release. r?jfkthame

Keep new css properties enabled past early beta.

Attachment #9091533 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(princess.shosho6030)

I've done a tonne of documentation work to get these new properties adequately represented on MDN; see https://github.com/mdn/sprints/issues/2104#issuecomment-531801054 for the details of what I did. I'm really excited to see these supported by default!

A review would be much appreciated when you have some spare time. Thanks!

Flags: needinfo?(dholbert)

(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #14)

I've done a tonne of documentation work [...]
A review would be much appreciated when you have some spare time. Thanks!

Thanks! I'll take a look later today.

princess.shosho6030 added flags: needinfo?(princess.shosho6030@gmail.com)

princess.shosho6030, it looks like you're a new user and you perhaps toggled a needinfo for yourself by mistake. Please don't play around with flags on bugs that you're not working on; it creates spam/cleanup-work for other people.

Flags: needinfo?(princess.shosho6030)
Flags: needinfo?(dholbert)

(In reply to Daniel Holbert [:dholbert] from comment #15)

(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #14)

I've done a tonne of documentation work [...]
A review would be much appreciated when you have some spare time. Thanks!

Thanks! I'll take a look later today.

(The documentation is great; I reviewed & gave feedback off-bug. Thanks, Chris!)

Noted as "Readability is now greatly improved on under- or overlined texts, including links. The lines will now be interrupted instead of crossing over a glyph."

You need to log in before you can comment on or make changes to this bug.