Closed Bug 1574108 Opened 3 months ago Closed 3 months ago

blocklist migration (ETP) using UI version 85 won't run in beta and release once it reaches version 70 because UI version 86 got uplifted

Categories

(Firefox :: Protections UI, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: aryx, Assigned: mcrawford)

References

(Blocks 1 open bug)

Details

(Whiteboard: [skyline][stp])

Attachments

(1 file)

Bug 1568900 added the blocklist migration (= UI version 85). Bug 1562601 migrated an autoplay pref (= UI version 86) and got uplifted to mozilla-beta. If bug 1568900 got uplifted, the migration would not run.

More important: Once the version increases, the content of the mozilla-beta repository replaces the mozilla-release one and the mozilla-central one mozilla-beta. Beta profiles already at UI version 86 won't run the blocklist migration because it uses a lower UI version as watershed.

Flags: needinfo?(jhofmann)

Maxx, for us this means that we need to do another UI migration with version 87 (or whatever the next available number is) to avoid getting skipped in Beta. Can you take this bug, please?

Thanks!

Flags: needinfo?(jhofmann) → needinfo?(mcrawford)
Priority: -- → P1
Whiteboard: [skyline][stp]
Assignee: nobody → mcrawford
Status: NEW → ASSIGNED
Flags: needinfo?(mcrawford)

Task assigned! I'm on it.

Keywords: checkin-needed

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/ca0ba0ca619f
blocklist migration (ETP) using UI version 85 won't run in beta and release once it reaches version 70 because UI version 86 got uplifted r=johannh

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.