Closed Bug 1574724 Opened 4 months ago Closed 4 months ago

No right click context menu on "Name or Email" field of "Contacts Sidebar"

Categories

(Thunderbird :: Message Compose Window, defect)

Desktop
Windows 10
defect
Not set

Tracking

(thunderbird_esr60 unaffected, thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: alice0775, Assigned: jorgk-bmo)

References

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Reproducible: always

Steps To Reproduce:

  1. Open email compose window
    File > New > Message
  2. Show Contacts Sidebar
    Press F9 key
  3. Right mouse button click on "Name or Email" filed of "Contacts Sidebar"

Actual Results:
Nothing happens

Expected Results:
Edit context menu should pop up.

Regression window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=0578849d7c953f13f6b8c6c57c1054b5a445c317&tochange=55a635377bed6cdeb57175d7e25a67b34dfce540
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a42caa9f04fc41044437ac56eab6f6086c841d9f&tochange=2abcefb31ba7b2a1c573edc5695b772826c6a078

Suspect:
55a635377bed6cdeb57175d7e25a67b34dfce540 Magnus Melin — Bug 1534913 - Port bug 1521280 [Remove search-textbox binding] to Thunderbird. r=jorgk

Attached image screenshot

Magnus Melin, Your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(mkmelin+mozilla)

Root cause is
c5798de806e28251aeda7d23123ab2b05eb7e8fb Tim Nguyen — Bug 1521280 - Convert search-textbox to a custom element. r=dao,bgrins

Blocks: 1534913
No longer regressed by: 1534913
Summary: No right click context menu on "Name or Email" filed of "Contacts Sidebar" → No right click context menu on "Name or Email" field of "Contacts Sidebar"
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)
Attachment #9086264 - Flags: review?(richard.marti)
Attachment #9086264 - Flags: review?(mkmelin+mozilla)
Attachment #9086264 - Flags: review?(geoff)
Attachment #9086264 - Flags: review?(acelists)
Attachment #9086264 - Flags: approval-comm-esr68+
Attachment #9086264 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0e7bfdf1b900
Restore context menu in abContactsPanel.xul (contacts sidebar). r=me DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

Thanks for filing this bug, Alice!!

Target Milestone: --- → Thunderbird 70.0
Attachment #9086264 - Flags: review?(richard.marti)
Attachment #9086264 - Flags: review?(mkmelin+mozilla)
Attachment #9086264 - Flags: review?(geoff)
Attachment #9086264 - Flags: review?(acelists)
Attachment #9086264 - Flags: review+
You need to log in before you can comment on or make changes to this bug.