Closed Bug 1574859 Opened 2 years ago Closed 2 years ago

icons on the tool bar are suddenly three times as big

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set
normal

Tracking

(thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: musiquegraeme, Assigned: Paenglab)

References

Details

Attachments

(3 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Opened Thunderbird

Actual results:

The icon on the tool bar was perhaps three times its usual size - its the default green jigsaw piece icon.

Expected results:

It should have been the normal size - same as the standard icons.. This icon is there because I have a Browser_action entry in my manifest.json. The same thing happens to the icons that I have in the compose window but I shrunk the icon. With this icon from the browser_action entry - it is the default icon and I can't resize it and anyway I feel like this is a bug to be fixed... though minor.

Summary: icons on the tool bar are suddenly twice as big → icons on the tool bar are suddenly three times as big

Do you see it also when Thunderbird is restarted with addons disabled?

Component: Untriaged → Toolbars and Tabs
Flags: needinfo?(musiquegraeme)

I presume not as the problem icons are all related to an addon - the default icon that comes when I have browser_action in the manifest.json and the icon that I use in my addon in the composer window. This had always been OK until the last but one beta and it increased. I coped with that by reducing it's size. Then in the latest beta, today, for some reason the browser_action icon stayed (previously it had only been there for a short time - don't know why - I removed it from the manifest.json) It was also super large.

Flags: needinfo?(musiquegraeme)

I experience something similar with the Gecko Profiler addon

Related to bug 1572946? NI Richard for theme, Geoff for add-ons.

Flags: needinfo?(richard.marti)
Flags: needinfo?(geoff)

Could be a toolkit add-ons thing. Even if it is the icons should have dimensions set on them but don't.

Flags: needinfo?(geoff)

We hadn't set a icon size. With defining a 64px icon it will show it in his original size.

With set to 18px (16px + 2px padding) it's correct now. Tested with the Gecko Profiler addon.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #9086732 - Flags: review?(alessandro)
Attachment #9086732 - Flags: approval-comm-beta?

Patch for ESR 68.

Attachment #9086733 - Flags: approval-comm-esr68?
Comment on attachment 9086732 [details] [diff] [review]
1574859-toolbarbutton-icon-size.patch

Review of attachment 9086732 [details] [diff] [review]:
-----------------------------------------------------------------

I don't this this is a complete solution as it causes smaller icons in the today pane to grow past their original intended size.
(See screenshot above)
Attachment #9086732 - Flags: review?(alessandro) → review-

Sorry, the rule wasn't specific enough.

Attachment #9086732 - Attachment is obsolete: true
Attachment #9086732 - Flags: approval-comm-beta?
Attachment #9086739 - Flags: review?(alessandro)
Attachment #9086739 - Flags: approval-comm-beta?

Patch for ESR 68.

Attachment #9086733 - Attachment is obsolete: true
Attachment #9086733 - Flags: approval-comm-esr68?
Attachment #9086740 - Flags: approval-comm-esr68?
Comment on attachment 9086739 [details] [diff] [review]
1574859-toolbarbutton-icon-size.patch

Review of attachment 9086739 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thank you.
Attachment #9086739 - Flags: review?(alessandro) → review+
Keywords: checkin-needed
Attachment #9086739 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #9086740 - Flags: approval-comm-esr68? → approval-comm-esr68+
Target Milestone: --- → Thunderbird 70.0
Version: 69 → 68

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c69de8e90f22
Set a size on toolbarbutton-icon. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Regressions: 1575612
Regressions: 1576290
You need to log in before you can comment on or make changes to this bug.