Closed Bug 1575415 Opened 5 months ago Closed 5 months ago

File picker shown instead of Application chooser when choosing what to do with a downloaded file

Categories

(Core :: Widget: Gtk, defect)

Unspecified
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 69+ verified
firefox68 --- wontfix
firefox69 + verified
firefox70 + verified

People

(Reporter: glandium, Assigned: glandium)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1524687 broke the component registration for the application chooser on Gtk builds, so that it's never used, and we instead get the file chooser. That's a UX regression (choosing an executable via a file picker to use as an application to open a downloaded file is dreadful compare to choosing an application)

STR:

Actual result:

  • A "Choose Helper Application" dialog that looks a lot like "Open File".

Expected result:

  • A "Choose Helper Application" dialog that only contains a list of applications to pick from.

Bug 1524687 landed in 67, so this affects 67, 68 and 69 as of now.

Bug 1278282 removed Gtk2 support, so MOZ_WIDGET_TOOLKIT is always "gtk3"
for Gtk builds, and never "gtk", which makes the current check never
match.

Blocks: 1575420
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/4b29e32f7290
Always register the nsApplicationChooser component in Gtk builds. r=froydnj

Comment on attachment 9086873 [details]
Bug 1575415 - Always register the nsApplicationChooser component in Gtk builds.

Beta/Release Uplift Approval Request

  • User impact if declined: UX regression for something that was there since Firefox 59.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See STR in comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only re-enables a component that was present since Firefox 59 and hasn't changed since, but was disabled due to a typo.
  • String changes made/needed: N/A
Attachment #9086873 - Flags: approval-mozilla-esr68?
Attachment #9086873 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
QA Whiteboard: [qa-triaged]
OS: Unspecified → Linux

Confirmed issue with 69.0b7.
Verified fix with 70.0a1 (2019-08-22) on Ubuntu 16.0.4.

Status: RESOLVED → VERIFIED

Comment on attachment 9086873 [details]
Bug 1575415 - Always register the nsApplicationChooser component in Gtk builds.

approved for 68.1esr and the last 69 beta

Attachment #9086873 - Flags: approval-mozilla-esr68?
Attachment #9086873 - Flags: approval-mozilla-esr68+
Attachment #9086873 - Flags: approval-mozilla-beta?
Attachment #9086873 - Flags: approval-mozilla-beta+

Verified with 69.0b16 and esr68.1.0 from taskCluster on Ubuntu 18.04.

Updating flag for beta as well.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.