Closed Bug 1576113 Opened 2 months ago Closed 2 months ago

Completely grey window on startup with gfx.core-animation.enabled enabled on Mac with 10.14 SDK

Categories

(Core :: Widget: Cocoa, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: standard8, Assigned: mstange)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

After bug 1574538 landed, my local Firefox builds are starting up with an almost completely grey window - the only items displayed are the window controls themselves.

Interacting with the window appears to work - I can get some popups from the bookmarks toolbar for instance.

If I download a treeherder build, then it works fine.

If I change the profile to set gfx.core-animation.enabled to false, then it starts working again.

As I'm using just the default .mozconfig with no sdk specification, I'm assuming this is a result of using the 10.14 SDK.

Oh dear, that's certainly not the intended effect.

Assignee: nobody → mstange
Status: NEW → ASSIGNED

This can be fixed by backing out https://hg.mozilla.org/integration/autoland/rev/2a82b5ce10e2 . I will do that tomorrow. More details to follow.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2093b28e6aa9
Back out revision 2a82b5ce10e2 because it causes trouble when building with the 10.14 SDK.
https://hg.mozilla.org/integration/mozilla-inbound/rev/0bc07ad7cfad
Add a comment.

Here's what the NSView hierarchy looks like when building with the 10.14 SDK:

When returning NO from _wantsFloatingTitlebar:

NSThemeFrame
    NSView // content view
        ChildView
            ...
    _NSThemeCloseWidget
    _NSThemeZoomWidget
    _NSThemeWidget
    NSThemeFrameTitleTextField

When returning YES from _wantsFloatingTitlebar:

NSThemeFrame
    NSView // content view
        ChildView
            ...
    NSVisualEffectView // full-window gray view
    NSTitlebarContainerView
        NSTitlebarView
            _NSThemeCloseWidget
            _NSThemeZoomWidget
            _NSThemeWidget
            NSTextField
        _NSTitlebarDecorationView

That NSVisualEffectView is not present when building with the 10.13 SDK or below. It's what renders the gray color. Our setContentView: override places the window's content view below that solid gray view, so nothing is shown.

To fix this, I re-instated the _wantsFloatingTitlebar override for now. I filed bug 1576387 and bug 1576391 for fixing this properly.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1576579
You need to log in before you can comment on or make changes to this bug.