Pasting text into textarea doesn't always redraw it correctly

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Stephane Moureau, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
If you make a pure text in TextEdit (after converting it with Cmd-Shift-T) copy
it and paste it in the main text field, the display is not always correct.
Just as if a part of the field content was not displayed, it's blank.
You must scroll to get it shown correctly.
It's not always reproducable, but happens very often.
No matter the page.
Build v0.4 20020715 16:03

Comment 1

16 years ago
wonky, ->pinkerton
Assignee: saari → pinkerton

Updated

16 years ago
Blocks: 147975

Comment 2

16 years ago
Stephane, you mean paste the text in a TEXTAREA element on a web page, right?
(Reporter)

Comment 3

16 years ago
Yes, that's right, like on this bug report page, additional comments.
I think this occurs (only) if the pasted text is long enough, probably the 
scroll of the text field has a problem and do not update its top area.

Comment 4

16 years ago
Stephane, could you attach an example TextEdit file?
(Reporter)

Comment 5

16 years ago
Created attachment 91687 [details]
text sample

text sample pasted in partly visible field will make an error in content area
update.
(Reporter)

Comment 6

16 years ago
Created attachment 91689 [details]
capture

capture, no matter the text, the previous attach was for another bug, just long
enough that's all.

Comment 7

16 years ago
WorksForMe using Chimera/20020718. I copied the text sample, and then,

1. Pasted it into the TEXTAREA
2. Selected all the text, deleted, and repeated.

I did this 25 times, and saw no display problems like those in the capture.

Comment 8

16 years ago
Stephane, when the text is on the clipboard, is it text or styled text?
(Finder/Edit/Show Clipboard)
(Reporter)

Comment 9

16 years ago
I've just some more tests, it seems the blank area appears only if the field in
which the text (not rtf) is pasted is partly hidden by the top or the bottom of
the window. In that case, a scroll occurs, but the area where the text is
visible correspond to the area that was visible before the scroll occurs. The
difference, what's blank is not updated. See the capture.

Comment 10

16 years ago
I can't repro this either, although I think I might have seen this before.  The
problem that I've seen seems to be related to plugins in other tabs rather than
paste in a textarea though.

Petersen - could you try this?
(Reporter)

Comment 11

16 years ago
Go to this bug report on bugzilla
Scroll the page to see only half of the Additional Comments field
Put blinking cursor into it
Paste a LONG text, with more lines than the field can show.
The page will scroll up and the field will be partly blank on its top part.

Comment 12

16 years ago
Okay, I see it now. Thanks, Stephane. Confirmed using Chimera/20020718.
probably some weird widget stuff. -> bryner
Assignee: pinkerton → bryner

Comment 14

16 years ago
please see also bug 161813 - may be related

Updated

16 years ago
Summary: Pasting Text clipping incorrect form contents → Pasting text into textarea doesn't always redraw it correctly

Comment 15

16 years ago
Patch from bug 153073 checked in, which fixes this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

15 years ago
No longer blocks: 147975
You need to log in before you can comment on or make changes to this bug.