Closed Bug 1576483 Opened 3 years ago Closed 3 years ago

Window buttons are missing on 10.13 when CoreAnimation is enabled (by default now) | no traffic light buttons, window controls are gone, close button disappeared

Categories

(Core :: Widget: Cocoa, defect, P1)

x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 --- unaffected
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + fixed
firefox100 --- verified

People

(Reporter: mstange, Assigned: mstange)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: Regression from bug 1574538. Can be easily fixed by flipping the CoreAnimation pref back off on Beta, if this bug is not fixed by then.

See bug 1576399 comment 6 and following: On 10.13, the window buttons have disappeared. They are present on at least 10.12 and 10.14, based on my testing.

Depends on: 1576391

Flore, could you please test this tryserver build and report whether it fixes the problem for you? It contains the patches from bug 1576391.

I'm also interested in the results on other version of macOS. For anyone reading this, if you're running 10.9, 10.10, 10.11, 10.13 or 10.15, it would be very helpful to me if you could download the build linked above and check the following:

  • Are the window buttons present, both with CoreAnimation on and off?
  • Are the window buttons entirely visible, or are they cut off, especially when checking the "Drag Space" option in the Customize panel?
  • Does window dragging work as expected? Are the right parts of the window chrome draggable?
  • Does tab dragging work as expected, especially in the very top parts of the window (in the place where there would usually be a titlebar), and does the window stay still when the tab is dragged?

(Please pay no attention to the power usage in that build. It does not contain any interesting changes compared to regular Nightly builds at the moment.)

Attached video screencast

I tested both with CoreAnimation on and off and there is no difference (in the window buttons, I mean).
For the other questions, I recorded my screen while doing what you asked, so you can see by yourself. I'd say everything is OK.
I don't know people with other versions of Mac OSX, Sébastien is using 10.13.6, too.

Looking good, thanks!

(adding some more words to the summary to help people find this bug more easily)

Summary: Window buttons are missing on 10.13 when CoreAnimation is enabled (by default now) → Window buttons are missing on 10.13 when CoreAnimation is enabled (by default now) | no traffic light buttons, window controls are gone, close button disappeared

I've landed the patches in bug 1576391. If they stick, they should arrive in Nightly some time tomorrow. At that point the testing on other platforms that I asked for in comment 1 can be done on regular Nightly builds instead of on the tryserver build.

Duplicate of this bug: 1576579

Bug 1576391 is on central, so this should be fixed now.

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Flags: qe-verify+
Has Regression Range: --- → yes

I was able to reproduce the issue without the fix on Mac 10.13 using build 70.0a1(20190825213650).
Verified as fixed on Mac 10.13 using Beta 100.0.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.