Closed Bug 1576498 Opened 1 year ago Closed 8 months ago

Intermittent leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)

Categories

(Core :: XPConnect, defect, P5)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: mccr8)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 obsolete file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263374643&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/aCH5gSlCTsO3v_d5VRactQ/runs/0/artifacts/public/logs/live_backing.log


Entering test: browser/components/extensions/test/browser/test-oop-extensions/browser_ext_windows_update.js

[task 2019-08-25T03:53:47.302Z] 03:53:47 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 3917
[task 2019-08-25T03:53:47.302Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.303Z] 03:53:47 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-25T03:53:47.303Z] 03:53:47 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-25T03:53:47.304Z] 03:53:47 INFO - 0 |TOTAL | 40 432| 54138 9|
[task 2019-08-25T03:53:47.305Z] 03:53:47 INFO - 26 |BackstagePass | 128 128| 3 1|
[task 2019-08-25T03:53:47.307Z] 03:53:47 INFO - 593 |XPCNativeInterface | 56 56| 56 1|
[task 2019-08-25T03:53:47.307Z] 03:53:47 INFO - 594 |XPCNativeMember | 16 16| 2541 1|
[task 2019-08-25T03:53:47.308Z] 03:53:47 INFO - 595 |XPCNativeSet | 32 32| 60 1|
[task 2019-08-25T03:53:47.308Z] 03:53:47 INFO - 596 |XPCWrappedNative | 96 96| 85 1|
[task 2019-08-25T03:53:47.309Z] 03:53:47 INFO - 597 |XPCWrappedNativeProto | 40 40| 29 1|
[task 2019-08-25T03:53:47.309Z] 03:53:47 INFO - 599 |XPCWrappedNativeTearOff | 32 32| 107 1|
[task 2019-08-25T03:53:47.310Z] 03:53:47 INFO - 795 |nsJSPrincipals | 24 24| 93 1|
[task 2019-08-25T03:53:47.310Z] 03:53:47 INFO - 901 |nsTArray_base | 8 8| 15800 1|
[task 2019-08-25T03:53:47.311Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.311Z] 03:53:47 INFO - nsTraceRefcnt::DumpStatistics: 949 entries
[task 2019-08-25T03:53:47.312Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 BackstagePass
[task 2019-08-25T03:53:47.312Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeInterface
[task 2019-08-25T03:53:47.313Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeMember
[task 2019-08-25T03:53:47.313Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeSet
[task 2019-08-25T03:53:47.314Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNative
[task 2019-08-25T03:53:47.314Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeProto
[task 2019-08-25T03:53:47.314Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeTearOff
[task 2019-08-25T03:53:47.315Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 nsJSPrincipals
[task 2019-08-25T03:53:47.315Z] 03:53:47 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTArray_base
[task 2019-08-25T03:53:47.317Z] 03:53:47 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)
[task 2019-08-25T03:53:47.317Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.318Z] 03:53:47 INFO - leakcheck | Processing leak log file /tmp/tmp6PxPwE.mozrunner/runtests_leaks_tab_pid4473.log
[task 2019-08-25T03:53:47.318Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.319Z] 03:53:47 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4473
[task 2019-08-25T03:53:47.319Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.320Z] 03:53:47 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2019-08-25T03:53:47.320Z] 03:53:47 INFO - | | Per-Inst Leaked| Total Rem|
[task 2019-08-25T03:53:47.321Z] 03:53:47 INFO - 0 |TOTAL | 38 0| 182254 0|
[task 2019-08-25T03:53:47.323Z] 03:53:47 INFO -
[task 2019-08-25T03:53:47.323Z] 03:53:47 INFO - nsTraceRefcnt::DumpStatistics: 864 entries
[task 2019-08-25T03:53:47.324Z] 03:53:47 INFO - TEST-PASS | leakcheck | tab no leaks detected!

Blocks: 1582881
No longer blocks: 1582881

This is leaking only on fission on browser/browser_ext_windows_update.js. Kris, do you wanna take a look over this?
Will make a patch to disable the test on fission meanwhile.

Flags: needinfo?(kmaglione+bmo)

(In reply to Cosmin Sabou [:CosminS] from comment #14)

This is leaking only on fission on browser/browser_ext_windows_update.js. Kris, do you wanna take a look over this?
Will make a patch to disable the test on fission meanwhile.

Why do you think that browser_ext_windows_update.js specifically is to blame? I'm asking because leaks are not usually attributable to a single test, though maybe with Fission that is easier.

In one log I looked at, it seemed like the process that leaked was associated with
browser/components/extensions/test/browser/browser_ext_tabs_readerMode.js

However, it looks like a lot of the errors here are being mis-starred. They aren't showing the 400-ish byte like the original issue, but instead are showing some kind of hang:

08:10:27 ERROR - TEST-UNEXPECTED-TIMEOUT | Last test finished | application timed out after 370 seconds with no output
34571 08:10:27 ERROR - Force-terminating active process(es).
36584 08:10:34 INFO - PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::(anonymous namespace)::RunWatchdog(void*)]
37660 08:10:34 INFO - TEST-UNEXPECTED-FAIL | leakcheck | default missing output line for total leaks!
38542 08:10:35 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab missing output line for total leaks!

I think those should actually be getting starred again bug 1358898, or maybe some other new bug.

Flags: needinfo?(kmaglione+bmo)

Kris, at least 10 logs I checked the last test before the leaks happened was always browser_ext_windows_update.js but on second thought that is probably because it's the last test of the chunk. You are right, there are failures starred that contain the crash in bug 1358898 but also the leak here like: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272277633&repo=mozilla-inbound&lineNumber=37890 will clean them up but the majority of failures have leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)

In case it is useful, the way I tracked down the leak to a single test is first I went to this line that listed the leak failure:
TEST-UNEXPECTED-FAIL | leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)

That is the summary of a leak log from a dozen or so lines back:
leakcheck | Processing leak log file /tmp/tmpCmpsba.mozrunner/runtests_leaks_tab_pid6778.log

That indicates that the PID of the process that leaked is 6778. In fact, you can just search the log for runtests_leaks_tab_pid6778.log to see where the log was created. Then you can search for 6778 around there, and see that it was created during that reader mode test, and goes away shortly after it.

Also, note that this approach will be much more effective for Fission tests than non-Fission tests, because with Fission we create many more content processes than when it is not enabled. With non-Fission there might be only, say, a dozen processes, whereas here we have around 250 of them.

Andrew, thank you for the info. After searching the logs the way you stated above I got the following test that are leaking:

browser_ext_tabs_onUpdated_filter x3
browser_ext_tabs_hide.js x2
browser_ext_tabs_events_order
browser_ext_tabs_sendMessage
browser_ext_browsingData_localStorage
browser_ext_menus
browser_ext_runtime_setUninstallURL
browser_ext_windows
browser_ext_tabs_discarded
browser_ext_tabs_saveAsPDF
browser_ext_menus_targetElement_shadow
browser_ext_contentscript_animate
browser_ext_incognito_views
browser_ext_contentscript_animate
browser_ext_tabs_create
browser_ext_browsingData_pluginData
browser_ext_devtools_panel
browser_ext_sidebarAction_click
browser_ext_tabs_executeScript_bad
browser_ext_sessions_getRecentlyClosed_private
browser_ext_tabs_create_url
browser_ext_sessions_getRecentlyClosed
browser_ext_sessions_restoreTab
browser_ext_menus_replace_menu_context
browser_ext_urlbar
browser_ext_contextMenus
browser_ext_menus_targetElement
browser_ext_tabs_query

for eg: this has runtests_leaks_tab_pid6739 https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272659408&repo=mozilla-central&lineNumber=37033 and leads me to TEST-START | browser/components/extensions/test/browser/browser_ext_tabs_query.js
Could you double check to see if that's correct? If that's the case then will abandon the disable revision cause the tests leaking are too random.

Attachment #9104773 - Attachment is obsolete: true

(In reply to Cosmin Sabou [:CosminS] from comment #20)

for eg: this has runtests_leaks_tab_pid6739 https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272659408&repo=mozilla-central&lineNumber=37033 and leads me to TEST-START | browser/components/extensions/test/browser/browser_ext_tabs_query.js
Could you double check to see if that's correct? If that's the case then will abandon the disable revision cause the tests leaking are too random.

Oh, sorry, I should have given you an actual example and linked to a log (like you did here). The pid you are looking for is the one for the first thing BEFORE the TEST-UNEXPECTED-FAIL, not the one after. (The test harness prints out the log, then prints out the result.) So for that log it is actually runtests_leaks_tab_pid2452.log

It looks like the process that leaked there was created during the test browser_ext_contextMenus_targetUrlPatterns.js, which does not quite match what I saw in comment 16, but that process is also loading readerModeArticle.html, so I still think the intermittent leak is associated with reader mode. I'd guess that the leak is caused by going into reader mode right before a process shuts down, and it is probably an issue even without Fission, but with the way Fission is set up right now, lots of tests end up running right before shut down. I'll try to think of a way to narrow down the issue a bit.

It looks like there are 3 tests in that directory that use the reader mode article, so maybe you could try disabling those with Fission and see if it helps in the mean time: https://searchfox.org/mozilla-central/search?q=readerModeArticle.html&case=false&regexp=false&path=extensions

My idea here would be to unconditionally dump out the name of the interface for leaking XPCWrappedNatives, as this comes up reasonably often. Then, from the failure log we could see what the nsIFoo is, which will hopefully give better information on what is leaking. One pattern I've seen before is something starts up an nsITimer after we've begun shutdown, but I don't see a timer in the actual reader mode JSM.

(In reply to Andrew McCreight [:mccr8] from comment #22)

My idea here would be to unconditionally dump out the name of the interface for leaking XPCWrappedNatives, as this comes up reasonably often. Then, from the failure log we could see what the nsIFoo is, which will hopefully give better information on what is leaking. One pattern I've seen before is something starts up an nsITimer after we've begun shutdown, but I don't see a timer in the actual reader mode JSM.

Yeah, I dunno. Maybe https://searchfox.org/mozilla-central/rev/11d9c7b7fa82fdfb8ac2a8f0864e9d8d5fe2b926/toolkit/components/reader/test/head.js#39 ? But I dunno.

I don't see any other leak intermittents on file for this type of thing. Andrew, if you have cycles to look at this, I expect you'll be quicker than me trying to figure this out... Happy to help with any reader-mode related questions?

Also, reader mode uses a different origin (about:reader?url=...) from the original page, so I suspect in fission this would /always/ cause a content process switch, and might therefore be triggering this?

(In reply to :Gijs (he/him) from comment #23)

I don't see any other leak intermittents on file for this type of thing. Andrew, if you have cycles to look at this, I expect you'll be quicker than me trying to figure this out... Happy to help with any reader-mode related questions?
There's bug 1434868 which looks similar, but there's been no non-Fission failures in that bug since August.

This isn't really actionable right now, but I'm hoping that with some nsIFoo information some code auditing will turn something up.

Also, reader mode uses a different origin (about:reader?url=...) from the original page, so I suspect in fission this would /always/ cause a content process switch, and might therefore be triggering this?

Yeah, could be.

Does setTimeout there in head.js use nsITimer?

(In reply to Andrew McCreight [:mccr8] from comment #24)

Does setTimeout there in head.js use nsITimer?

I don't think so? head.js and browser_*.js get run in a window scope of the browser.xhtml chrome window, so they have access to that setTimeout() without any further work.

Assignee: nobody → continuation

I added some logging to try to figure out what was leaking but the XPCWrappedNative in question just has nsISupports and no tearoffs as interfaces. I don't know if that's a sign of something or maybe the tearoffs were removed prior to the start of XPCWrappedNative::SystemIsBeingShutDown().

In my slow-going investigation, I did figure out one bit of information: the XPCWN being leaked is the wrapper for the JSM shared global. (At least, it was allocated inside a call from mozJSComponentLoader::GetSharedGlobal() to XPCWrappedNative::WrapNewGlobal().)

Depends on: 1580212
Whiteboard: [stockwell disable-recommended]

This leak is continuing to occur in Fission mochitests. I looked at the failures from today and yesterday. browser/base/content/test/tabs/browser_multiselect_tabs_mute_unmute.js failed 13 times(!), browser/base/content/test/tabs/browser_multiselect_tabs_bookmark.js failed 3 times, and browser/base/content/test/tabs/browser_multiselect_tabs_event.js failed twice.

There were also individual failures in the following tests:
browser/base/content/test/performance/browser_preferences_usage.js
browser/base/content/test/tabs/browser_multiselect_tabs_reload.js
browser/base/content/test/tabs/browser_multiselect_tabs_clear_selection_when_tab_switch.js
browser/base/content/test/tabs/browser_multiselect_tabs_event.js
browser/components/privatebrowsing/test/browser/browser_privatebrowsing_geoprompt.js
browser/base/content/test/general/browser_beforeunload_duplicate_dialogs.js

At least judging by the test name, multiselect is somehow an issue.

Depends on: 1595191
Whiteboard: [stockwell disable-recommended] → [comment 31]

Unfortunately my patch in bug 1580212 doesn't seem to have had any impact on the overall volume of failures.

Andrew should we start disabling tests on fission here?

Flags: needinfo?(continuation)
Depends on: 1596609

(In reply to Andreea Pavel [:apavel] from comment #34)

Andrew should we start disabling tests on fission here?

I've been trying to figure out what is causing the leak, but I haven't figured anything out yet. I put a patch bug 1596609 about changing the behavior of the most frequent offenders to hopefully reduce the failure rate here. The directory I patched in bug 1580212 hasn't leaked like this any more, but I don't know for sure if that's due to my patch or something else.

Flags: needinfo?(continuation)
Whiteboard: [comment 31][stockwell disable-recommended] → [comment 31][comment 35][waiting on bug 1596609]
Whiteboard: [comment 31][comment 35][waiting on bug 1596609] → [comment 35][waiting on bug 1596609]
Whiteboard: [comment 35][waiting on bug 1596609][stockwell disable-recommended] → [comment 35][waiting on bug 1596609]
Fission Milestone: --- → M4.1

There were 10 failures on 10/18, and only a couple since then, so I think bug 1596609 has gotten this failure rate to a more reasonable level.

Whiteboard: [comment 35][waiting on bug 1596609][stockwell disable-recommended] → [Comment 39]
Whiteboard: [Comment 39][stockwell disable-recommended] → [Comment 39]

There are still some failures here in Fission tests, but I think the failure rate has dropped low enough as to not be bad enough to cause Fission tests to be turned off, and there's some easy work arounds if it flares up again, so I'm clearing the 4.1 milestone.

Fission Milestone: M4.1 → ---

This is frequently failing, only on Fission. :mccr8, do we know what we're leaking / why? And/or can that be determined from the test output?

Flags: needinfo?(continuation)

(In reply to :Gijs (he/him) from comment #52)

This is frequently failing, only on Fission. :mccr8, do we know what we're leaking / why? And/or can that be determined from the test output?

From when I last looked at this, it seemed like the leak was the JSM shared global. Aggressively reusing Fission processes papered over the leaks before. I suspect there's a race condition when we shut down a content process right after we start it up.

Component: Untriaged → XPConnect
Flags: needinfo?(continuation)
Product: WebExtensions → Core

This is failing on linux64 debug and there are 24 failures in the last 7 days, all fission.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=286740535&repo=autoland&lineNumber=29726

[task 2020-01-28T15:23:39.692Z] 15:23:39 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_view_resultTypes_display.js
[task 2020-01-28T15:23:40.009Z] 15:23:40 INFO - GECKO(5211) | [Parent 5211: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7f8b19b85000 == 7 [pid = 5211] [id = {a314d00e-8827-412e-b57e-9762b5fb5ff8}]
[task 2020-01-28T15:23:40.009Z] 15:23:40 INFO - GECKO(5211) | [Parent 5211: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 91 (0x7f8b207615c0) [pid = 5211] [serial = 448] [outer = (nil)]
[task 2020-01-28T15:23:40.009Z] 15:23:40 INFO - GECKO(5211) | [Parent 5211: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 92 (0x7f8b19cd5800) [pid = 5211] [serial = 449] [outer = 0x7f8b207615c0]

[task 2020-01-28T15:24:02.668Z] 15:24:02 INFO - nsTraceRefcnt::DumpStatistics: 879 entries
[task 2020-01-28T15:24:02.668Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 BackstagePass
[task 2020-01-28T15:24:02.669Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeInterface
[task 2020-01-28T15:24:02.669Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeMember
[task 2020-01-28T15:24:02.670Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeSet
[task 2020-01-28T15:24:02.670Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNative
[task 2020-01-28T15:24:02.672Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeProto
[task 2020-01-28T15:24:02.672Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeTearOff
[task 2020-01-28T15:24:02.673Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 nsJSPrincipals
[task 2020-01-28T15:24:02.673Z] 15:24:02 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTArray_base
[task 2020-01-28T15:24:02.673Z] 15:24:02 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)
[task 2020-01-28T15:24:02.674Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.674Z] 15:24:02 INFO - leakcheck | Processing leak log file /tmp/tmpG5vBds.mozrunner/runtests_leaks_tab_pid5683.log
[task 2020-01-28T15:24:02.675Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.675Z] 15:24:02 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5683
[task 2020-01-28T15:24:02.675Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.676Z] 15:24:02 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-28T15:24:02.676Z] 15:24:02 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-28T15:24:02.677Z] 15:24:02 INFO - 0 |TOTAL | 37 0| 173819 0|
[task 2020-01-28T15:24:02.677Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.678Z] 15:24:02 INFO - nsTraceRefcnt::DumpStatistics: 863 entries
[task 2020-01-28T15:24:02.678Z] 15:24:02 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-28T15:24:02.678Z] 15:24:02 INFO - leakcheck | Processing leak log file /tmp/tmpG5vBds.mozrunner/runtests_leaks_tab_pid7661.log
[task 2020-01-28T15:24:02.680Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.681Z] 15:24:02 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7661
[task 2020-01-28T15:24:02.681Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.681Z] 15:24:02 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-28T15:24:02.682Z] 15:24:02 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-28T15:24:02.682Z] 15:24:02 INFO - 0 |TOTAL | 43 0| 32400 0|
[task 2020-01-28T15:24:02.683Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.683Z] 15:24:02 INFO - nsTraceRefcnt::DumpStatistics: 868 entries
[task 2020-01-28T15:24:02.684Z] 15:24:02 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-28T15:24:02.685Z] 15:24:02 INFO - leakcheck | Processing leak log file /tmp/tmpG5vBds.mozrunner/runtests_leaks_tab_pid5632.log
[task 2020-01-28T15:24:02.686Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.686Z] 15:24:02 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5632
[task 2020-01-28T15:24:02.687Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.687Z] 15:24:02 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-28T15:24:02.688Z] 15:24:02 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-28T15:24:02.688Z] 15:24:02 INFO - 0 |TOTAL | 45 0| 19245 0|
[task 2020-01-28T15:24:02.689Z] 15:24:02 INFO -
[task 2020-01-28T15:24:02.689Z] 15:24:02 INFO - nsTraceRefcnt::DumpStatistics: 604 entries
[task 2020-01-28T15:24:02.690Z] 15:24:02 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-28T15:24:02.690Z] 15:24:02 INFO - leakcheck | Processing leak log file /tmp/tmpG5vBds.mozrunner/runtests_leaks_tab_pid8475.log

Gijs are you working on this?

Flags: needinfo?(gijskruitbosch+bugs)
Whiteboard: [Comment 39]

I can take a shot at papering this over using a pref like I did in bug 1596609. (I should really get around to actually fixing this...)

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Andrew McCreight [:mccr8] from comment #55)

I can take a shot at papering this over using a pref like I did in bug 1596609. (I should really get around to actually fixing this...)

Thank you.

Depends on: 1612179
No longer depends on: 1595191
Depends on: 1612364

There are 21 failures associated to this bug in the last 7 days. These are occurring on linux1804-64 debug.

recent log: https://treeherder.mozilla.org/logviewer.html#?job_id=291117708&repo=autoland

Whiteboard: [stockwell needswork]

There are 21 failures associated to this bug in the last 7 days. These are occurring on linux1804-64 debug.

recent log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=295848289&repo=autoland&lineNumber=18516

[task 2020-04-01T23:22:35.401Z] 23:22:35 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-04-01T23:22:35.402Z] 23:22:35 INFO - leakcheck | Processing leak log file /tmp/tmpoSTZ15.mozrunner/runtests_leaks_tab_pid1462.log
[task 2020-04-01T23:22:35.402Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.403Z] 23:22:35 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1462
[task 2020-04-01T23:22:35.403Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.404Z] 23:22:35 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-04-01T23:22:35.404Z] 23:22:35 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-04-01T23:22:35.405Z] 23:22:35 INFO - 0 |TOTAL | 40 0| 355169 0|
[task 2020-04-01T23:22:35.406Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.407Z] 23:22:35 INFO - nsTraceRefcnt::DumpStatistics: 1080 entries
[task 2020-04-01T23:22:35.407Z] 23:22:35 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-04-01T23:22:35.408Z] 23:22:35 INFO - leakcheck | Processing leak log file /tmp/tmpoSTZ15.mozrunner/runtests_leaks_tab_pid1879.log
[task 2020-04-01T23:22:35.408Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.409Z] 23:22:35 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1879
[task 2020-04-01T23:22:35.409Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.409Z] 23:22:35 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-04-01T23:22:35.410Z] 23:22:35 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-04-01T23:22:35.410Z] 23:22:35 INFO - 0 |TOTAL | 41 432| 34821 9|
[task 2020-04-01T23:22:35.411Z] 23:22:35 INFO - 23 |BackstagePass | 128 128| 3 1|
[task 2020-04-01T23:22:35.412Z] 23:22:35 INFO - 527 |XPCNativeInterface | 56 56| 46 1|
[task 2020-04-01T23:22:35.413Z] 23:22:35 INFO - 528 |XPCNativeMember | 16 16| 2130 1|
[task 2020-04-01T23:22:35.414Z] 23:22:35 INFO - 529 |XPCNativeSet | 32 32| 51 1|
[task 2020-04-01T23:22:35.414Z] 23:22:35 INFO - 530 |XPCWrappedNative | 96 96| 71 1|
[task 2020-04-01T23:22:35.415Z] 23:22:35 INFO - 531 |XPCWrappedNativeProto | 40 40| 27 1|
[task 2020-04-01T23:22:35.415Z] 23:22:35 INFO - 533 |XPCWrappedNativeTearOff | 32 32| 92 1|
[task 2020-04-01T23:22:35.416Z] 23:22:35 INFO - 717 |nsJSPrincipals | 24 24| 54 1|
[task 2020-04-01T23:22:35.416Z] 23:22:35 INFO - 813 |nsTArray_base | 8 8| 10578 1|
[task 2020-04-01T23:22:35.417Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.418Z] 23:22:35 INFO - nsTraceRefcnt::DumpStatistics: 852 entries
[task 2020-04-01T23:22:35.418Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 BackstagePass
[task 2020-04-01T23:22:35.418Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeInterface
[task 2020-04-01T23:22:35.419Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeMember
[task 2020-04-01T23:22:35.419Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCNativeSet
[task 2020-04-01T23:22:35.420Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNative
[task 2020-04-01T23:22:35.421Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeProto
[task 2020-04-01T23:22:35.421Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 XPCWrappedNativeTearOff
[task 2020-04-01T23:22:35.422Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 nsJSPrincipals
[task 2020-04-01T23:22:35.422Z] 23:22:35 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTArray_base
[task 2020-04-01T23:22:35.423Z] 23:22:35 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 432 bytes leaked (BackstagePass, XPCNativeInterface, XPCNativeMember, XPCNativeSet, XPCWrappedNative, ...)
[task 2020-04-01T23:22:35.423Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.424Z] 23:22:35 INFO - leakcheck | Processing leak log file /tmp/tmpoSTZ15.mozrunner/runtests_leaks_tab_pid5332.log
[task 2020-04-01T23:22:35.424Z] 23:22:35 INFO -
[task 2020-04-01T23:22:35.425Z] 23:22:35 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5332

:mccr8 can you take a look?

Flags: needinfo?(continuation)

The biggest chunk of recent failures is in the browser/base/content/test/general/ directory, but they are scattered around in other directories, too.

Andrew is there anything we can do here?

I have a patch up for review in bug 1612364 that I hope will fix this.

Flags: needinfo?(continuation)
Keywords: regression

It looks like this hasn't happened since bug 1612364 landed. I'll keep an eye on this for a few more days.

I'm also going to land bug 1628052 at some point, which will roll back the behavior changes I landed to work around this issue, which could cause this to reappear if I'm wrong.

Duplicate of this bug: 1434868
See Also: → 1594985

Still no occurrences since I landed my patch.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
See Also: → 1636624
You need to log in before you can comment on or make changes to this bug.