Closed Bug 1578945 Opened 6 months ago Closed 2 months ago

Remove old audio competing mechanism in AudioChannelService

Categories

(Core :: Audio/Video: Playback, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

We have implemented new audio focus management in bug1565689 which would allow us to have one tab playing audio at the same time no matter we're using e10s or Fission.

Therefore, we can remove the old pref dom.audiochannel.audioCompeting and dom.audiochannel.audioCompeting.allAgents, which are only work on non-e10s mode.

In addition, the audio competing is only used by default on Fennec, but Fennec is now no longer following the latest m-c, it's using ESR68. So even if our new audio focus management is not on by default on Android, it won't affect current behavior on Fennec. We can 100% sure that we won't need those code for old audio competing anymore.

We have implemented new audio focus management in bug1565689 which would allow us to have one tab playing audio at the same time no matter we're using e10s or Fission.

Therefore, we can remove the old pref dom.audiochannel.audioCompeting and dom.audiochannel.audioCompeting.allAgents, which are only work on non-e10s mode.

In addition, the audio competing is only used by default on Fennec, but Fennec is now no longer following the latest m-c, it's using ESR68. So even if our new audio focus management is not on by default on Android, it won't affect current behavior on Fennec. We can 100% sure that we won't need those code for old audio competing anymore.

Sorry, I just notice that we can't remove this right now, because these audio competing code is still running on Fenix. Therefore, instead of removing them immeidiately, I would start to enable new audio focus managment on Fenix Nightly only, and see how it works. If it works well, then we will turn it on Fenix Release, and then replace the old mechanism steps by steps.

Depends on: 1582802

There are some r+ patches which didn't land and no activity in this bug for 2 weeks.
:alwu, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(alwu)

I will wait more time to see if enabling new audio competing on Fenix causes any regression or not, in order to decide whether we would like to land these two patches.

Flags: needinfo?(alwu)

We've enabled new the audio competing mechanism on Android Nightly two months ago, and we didn't get any bug report about it, so it's time to enable that for all versions on Android.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1582802

Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fab28f89bb44
part1 : remove handling audio focus related code in AudioChannelService. r=baku,sebastian
https://hg.mozilla.org/integration/autoland/rev/9f2c46528648
part2 : remove old audio competing related tests. r=baku
https://hg.mozilla.org/integration/autoland/rev/6309c331099d
part3 : enable new audio competing mechanism for all versions on Android. r=sebastian
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.