Closed Bug 1578982 Opened 3 months ago Closed 3 months ago

Category color not displayed in calendar if category name contains space or other escaped non-ASCII characters

Categories

(Calendar :: Calendar Views, defect)

Lightning 68
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: marc.maeder, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

If the category name contains a space e.g. "MC Bern", then the selected color is not displayed in the calendar. This problem is since version 68.

Actual results:

The category color is only displayed in light gray in the calendar.

Expected results:

None of the selected colors are displayed in the calendar. This only works if the category name does not contain a space. Can you make spaces in the category name possible again with the colors?

Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 68 → unspecified
Component: General → Calendar Views
Keywords: regression
Summary: Category name and color → Category color not displayed in calendar if category name contains space
Version: unspecified → Lightning 7.0
Duplicate of this bug: 1580671

Could the be regression from bug 1561528 too?

Flags: needinfo?(geoff)

Yes it is. The space is getting doubly-encoded.

Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(geoff)
Attachment #9092947 - Flags: review?(paul)
Attachment #9092947 - Flags: approval-calendar-esr?(paul)
Attachment #9092947 - Flags: approval-calendar-beta?(paul)
Summary: Category color not displayed in calendar if category name contains space → Category color not displayed in calendar if category name contains space or other escaped non-ASCII characters
Comment on attachment 9092947 [details] [diff] [review]
1578982-category-css-1.diff

Review of attachment 9092947 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.  With this patch the problem goes away.  Events have the correct category color applied when the category name has a space.
Attachment #9092947 - Flags: review?(paul)
Attachment #9092947 - Flags: review+
Attachment #9092947 - Flags: approval-calendar-esr?(paul)
Attachment #9092947 - Flags: approval-calendar-esr+
Attachment #9092947 - Flags: approval-calendar-beta?(paul)
Attachment #9092947 - Flags: approval-calendar-beta+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/944c4a8f2b23
Fix category colour display if category name contains space; r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 71
Duplicate of this bug: 1586448
You need to log in before you can comment on or make changes to this bug.