The Mail Start Page does not load

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Devin Henderson, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I'm using the latest trunk, build 2002071708, and when I launch mail/news the
mail start page is not loaded. It is set to be loaded in Preferences > Mail &
Newsgroups. This started about a week and a half ago. I download nightlies daily
:) and this behavior has remained since I first noticed it. Selecting 'Mail
Start Page' from the 'Go' menu within mail/news does nothing either. Is this
just a profile corruption? I don't know of anything that would have corrupted my
profile. Everything else has been working fine and I don't have N6 or N7
installed so my profile hasn't been corrupted that way.
Strange.. I haven't checked this before, but you are infact correct :)
Have you tried with a fresh profile ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Created a fresh profile, set up a new mail account with wizard when mail/news
first launched, still does the same thing: Mail Start Page does not load on
mail/news startup and 'Go' -> 'Mail Start Page' also does nothing.
(Assignee)

Comment 3

16 years ago
jag, loadStartPage tries to reference window.frames["messagepane"] which used to
retrieve the window in a <browser type="content-primary" name="messagepane"> -
would I be correct in assuming that all uses have to be changed to window.content?

Updated

16 years ago
QA Contact: olgam → esther

Comment 4

16 years ago
Neil: if that <browser> always has type="content-primary" then yes, you can just
replace it with window.content. If not, you need to add an id attribute and do
document.getElementById("messagepane").contentWindow to get to the same window.
(Assignee)

Comment 5

16 years ago
Created attachment 91948 [details] [diff] [review]
Switch to using window.content because the browsers have type="content-primary"
(Assignee)

Updated

16 years ago
Keywords: patch, review, ui

Updated

16 years ago
Attachment #91948 - Flags: review+
(Assignee)

Updated

16 years ago
Blocks: 158333

Comment 6

16 years ago
Comment on attachment 91948 [details] [diff] [review]
Switch to using window.content because the browsers have type="content-primary"

This change looks good to me, though it might be good to keep GetMessagePane
and SetFocusMessagePane around. sspitzer, your call.
(Assignee)

Comment 7

16 years ago
Comment on attachment 91948 [details] [diff] [review]
Switch to using window.content because the browsers have type="content-primary"

jag, I removed GetMessagePaneFrame because all it does is cache window.content
in window.gMessagePaneFrame :-)

Comment 8

16 years ago
Right, so the reason to keep it would be that you now have the current
implementation (window.content) of how to get the message pane in one place,
while referring to the higher level thing you want to do (get the message pane)
from the call sites. If at some point the implementation changes, you have one
place to change. But like I said, it's up to sspitzer whether he wants that or not.
(Assignee)

Comment 9

16 years ago
Actually before you stopped it from working window.frames['messsagepane'] was
used in three locations :-)

Comment 10

16 years ago
Uh huh. See how much easier your fix could've been if they had been using this
function all the way through? Just one place to change from .frames to .content ;-)
(Assignee)

Comment 11

16 years ago
Created attachment 92381 [details] [diff] [review]
jag, how's this version?

Comment 12

16 years ago
Comment on attachment 92381 [details] [diff] [review]
jag, how's this version?

good fix.

r=ssu
Attachment #92381 - Flags: review+
Comment on attachment 92381 [details] [diff] [review]
jag, how's this version?

sr=sspitzer
Attachment #92381 - Flags: superreview+

Comment 14

16 years ago
reassigning to Neil.  I will check in the patch for Neil when a=drivers.
Assignee: sspitzer → neil

Comment 15

16 years ago
Comment on attachment 92381 [details] [diff] [review]
jag, how's this version?

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #92381 - Flags: approval+

Comment 16

16 years ago
patch checked in to trunk only.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
*** Bug 159916 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

16 years ago
still deoesn't work for me in latest nightly 2002073008 winXP. has this been fixed?

Comment 19

16 years ago
not sure how it happened, but only part of the patch was checked in.  The rest
has now been checked in and it should be working now (just tested it).

really fixed on trunk now.

Comment 20

16 years ago
*** Bug 160244 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
Using trunk builds 20021121 on winxp, macosx and linux this is fixed.  Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.