Closed Bug 1580791 Opened 1 year ago Closed 1 year ago

The "Paste & Go" option do nothing if the "@<search_engine>" string is displayed in the "Address Bar"

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1580792
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: mcoman, Unassigned)

Details

Attachments

(1 file)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Beta 70.0b5 - Build ID: 20190909162732
  • Firefox Nightly 71.0a1 - Build ID: 20190912094122

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have the latest Firefox Beta or Nightly installed.
  • Have any text copied to clipboard.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Open a new tab and click the "Amazon" top search shortcut.
  3. Right-click in the "Address Bar" and select the "Paste & Go" option.
  4. Observe the behavior.

[Expected result]:

  • A search is performed with the default search engine.

[Actual result]:

  • Nothing happens.

[Regression Window]:

  • Considering the fact that this issue is not reproducible on latest Firefox Release (69.0), using the "mozregression" tool I have managed to find the following regression:

Last good revision: 47e72c204ef61c34509e430c0976f4db680e384a
First bad revision: 580d975db59096011e93150a04856a15b9e8812d
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=47e72c204ef61c34509e430c0976f4db680e384a&tochange=580d975db59096011e93150a04856a15b9e8812d

From the pushlog, it seems that bug 1551598 caused this issue.

[Notes]:

  • This issue is also reproducible if the "@amazon" string is typed in the "Address Bar".
  • This issue is reproducible with all the top sites search shortcuts (@google; @duckduckgo, etc)
  • Attached a screen recording of the issue.

This is probably the same as bug 1580792.

Depends on: 1580792
Priority: -- → P3
No longer blocks: urlbar-update-1
Status: NEW → RESOLVED
Closed: 1 year ago
No longer depends on: 1580792
No longer regressed by: 1551598
Resolution: --- → DUPLICATE
Duplicate of bug: 1580792
You need to log in before you can comment on or make changes to this bug.