Closed Bug 1581314 Opened 7 months ago Closed 5 months ago

Introduce a framework for expanding certerror code to handle neterrors

Categories

(SeaMonkey :: General, task)

task
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

We currently use toolkit's neterror handling which is basic.
This patch ports parts of the following:

  • Bug 1240594 - Merge about:neterror and about:certerror UI code
  • Bug 1267514 - Fix about:neterror generic fallback text when there is no available title/description for the error
  • Bug 989197 - Show alternate UI in cert error pages when a captive portal is active
  • Bug 1394462 - Update dnsNotFound error copy and illustration

There should be no visible change to the UI with this patch, it just creates the framework for further enhancement.

Attached patch Add framework (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: One minor change to one entity.

Attachment #9093006 - Flags: review?(frgrahl)
Attachment #9093006 - Flags: approval-comm-release?
Attachment #9093006 - Flags: approval-comm-esr60?
Comment on attachment 9093006 [details] [diff] [review]
Add framework

LGTM.  Tested with https://badssl.com/
I am assuming that for Bug 989197 follow-ups are needed?
Attachment #9093006 - Flags: review?(frgrahl)
Attachment #9093006 - Flags: review+
Attachment #9093006 - Flags: approval-comm-release?
Attachment #9093006 - Flags: approval-comm-release+
Attachment #9093006 - Flags: approval-comm-esr60?
Attachment #9093006 - Flags: approval-comm-esr60+

Slight adjustment to how boldness is done

Attachment #9093006 - Attachment is obsolete: true
Attachment #9100695 - Flags: review?(frgrahl)
Attachment #9100695 - Flags: approval-comm-release?
Attachment #9100695 - Flags: approval-comm-esr60?

(In reply to Frank-Rainer Grahl (:frg) from comment #2)

Comment on attachment 9093006 [details] [diff] [review]
Add framework

LGTM. Tested with https://badssl.com/
I am assuming that for Bug 989197 follow-ups are needed?

Yes, that will be a separate bug.

Comment on attachment 9100695 [details] [diff] [review]
Add framework v1.1

LGTM
Attachment #9100695 - Flags: review?(frgrahl)
Attachment #9100695 - Flags: review+
Attachment #9100695 - Flags: approval-comm-release?
Attachment #9100695 - Flags: approval-comm-release+
Attachment #9100695 - Flags: approval-comm-esr60?
Attachment #9100695 - Flags: approval-comm-esr60+
Blocks: 1591749

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/57ed65500348
Introduce a framework for expanding certerror code to handle neterrors. r=frg

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.