Closed Bug 15817 Opened 20 years ago Closed 20 years ago

[DOGFOOD]MLK: every GIFDecoder leaks

Categories

(Core :: ImageLib, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: warrensomebody, Assigned: pnunn)

References

Details

(Whiteboard: [PDT-])

Bloaty: Refcounting and Memory Bloat
Statistics

|<-------Name------>|<--------------References-------------->|<----------------
Objects---------------->|<------Size----->|
                               Rem    Total      Mean       StdDev       Rem
Total      Mean       StdDev Per-Class      Rem
 139 GIFDecoder                239      239 (  120.00 +/-   119.33)      239
239 (  120.00 +/-   119.33)       12     2868
Status: NEW → ASSIGNED
Target Milestone: M11
Summary: [leak] every GIFDecoder leaks → [DOGFOOD][leak] every GIFDecoder leaks
Blocks: 6409
How large and often is this leak?
We need more info to assist in PDT+ vs. PDT- decision.  How bad is this leak?
Thanks!
Running viewer with throbber removed:
 sample#0 to sample#2 (with 1 jpg and 2 animated GIFs)

GIFDecoder: 12 bytes/instance, and total leak of 24 bytes.
GIFModule:  16 bytes/instance, and total leak of 0 bytes. (yippee!)

Since GIF are used in tool bars and throbber the incidence for apprunner
is going to be much higher.

Running apprunner/mozilla. First site is mozilla.org, sample#2, sample#0:
GIFDecoder: 12 bytes/instance, and total leak of 600 bytes.
GIFModule:  16 bytes/instance, and total leak of 0 bytes. (yippee!)
*** Bug 7196 has been marked as a duplicate of this bug. ***
*** Bug 6409 has been marked as a duplicate of this bug. ***
[Note to self: please verify bug #6409 as part of this bug verification.]
Summary: [DOGFOOD][leak] every GIFDecoder leaks → [DOGFOOD]MLK: every GIFDecoder leaks
Whiteboard: [PDT-]
This leak not big enough for dogfood.  Marking [PDT-]
Blocks: 17907
Target Milestone: M11 → M12
Blocks: 6394
No longer blocks: 6394
*** Bug 6394 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This leak was fixed by other checkins, probably
by leak fixes in other modules (gfx, layout, etc.)

I've gone back as far as tinderbox bloaty goes
and the nsGIFModule and the GIFDecoder are
not showing any leaks from 11-25-99.
-pn
This was fixed when the ImageManagerImpl was converted to a service on 11/23/99.
see bug 15820.

Neeti
Status: RESOLVED → VERIFIED
Rubber-stamping as Verified/Fixed. (QA has been asked not to verify memory leak
bugs due to bug overload.)

Will also check 6409 next, and re-open this bug if 6409 lingers.
No longer blocks: 17907
You need to log in before you can comment on or make changes to this bug.