All users were logged out of Bugzilla on October 13th, 2018

Plugin context menus don't show up

RESOLVED DUPLICATE of bug 192276

Status

RESOLVED DUPLICATE of bug 192276
17 years ago
15 years ago

People

(Reporter: chrispetersen, Assigned: sfraser_bugs)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build: 2002-07-19-05
Platform: OS X 10.1.5
Expected Results: Control-click on real content should display the plugin's
contextual menu.

What I got: Browser's contexual menu appears rather than the plugin's.

Steps to reproduce:

1) Open test case
2) After plugin is intialized, control click on real content that appear.
3) Browser's contextual menus appear  rather than the plugin's.
4) If you try these same steps in a OSX Mozilla build, the plugin's menu will
appear and function.
(Reporter)

Comment 1

17 years ago
Created attachment 91977 [details]
Simple test case

Plugin's contextual menu will not appear when pressing control-click on movie
content.

Comment 2

17 years ago
Confirmed using Chimera/20020718, but it seems to be the case with any plug-in
in Chimera; I tested QT6 and Flash 6 also, with no success. Revising summary.
Summary: Real Player's plugin contextual menu is not appearing when invoked by user → Plug-in contextual menus don't appear when invoked by user
(Reporter)

Comment 3

17 years ago
For me , I can get both QT and Flash plugins to display their own contextual
menu. Pressing control key - clicking produces the plug-in menu using
2002-07-19-05 NB. See attachments.
(Reporter)

Comment 4

17 years ago
Created attachment 92114 [details]
Screen shot at macromedia.com
(Reporter)

Comment 5

17 years ago
Created attachment 92115 [details]
Screen shot at apple.com

Updated

17 years ago
Blocks: 147975

Comment 6

17 years ago
peterl, how did you fix this in mozilla proper?
Assignee: saari → bnesse

Comment 7

17 years ago
So let me get this straight, it works for other plugins in Chimera but not with
Real's new OSX beta?
(Reporter)

Comment 8

17 years ago
That's the case for me. However, Greg K mentioned he was having a problem with
other plugins though.

Comment 9

17 years ago
Brian just showed me that the QT volume menu is missing in recent mozilla trunk
and branch builds:
http://www.apple.com/trailers/wb/t3/medium.html

It seems to be a few week old regression. I'm still trying to narrow it down.

Comment 10

17 years ago
Okay; using Chimera/20020722, contextual menus still don't appear over Real
plug-in content.

Also, it appears the contextual menu appears over QT content using
control+click, but not the right button on my Kensington mouse (which works in
Mozilla).
(Assignee)

Updated

16 years ago
Component: Page Layout → Plug-ins
Summary: Plug-in contextual menus don't appear when invoked by user → Real: Plug-in contextual menus don't appear when invoked by user
(Assignee)

Comment 11

16 years ago
Confirming the bug still exists.

Comment 12

16 years ago
->peterl
Assignee: bnesse → peterl
(Assignee)

Comment 13

16 years ago
Related to bug 180591?
(Assignee)

Comment 14

16 years ago
This is addressed by the patch in bug 181947. Taking.
Assignee: peterl → sfraser
Summary: Real: Plug-in contextual menus don't appear when invoked by user → Plugin context menus don't show up
(Assignee)

Comment 15

16 years ago
*** Bug 181573 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

16 years ago
*** Bug 180591 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

16 years ago
Yes, the context menus for the real plugin is now displaying in the latest
Chimera build (2002-11-26-04 NB).
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 147975

Comment 19

16 years ago
This is busted in Camino .7 bld #2003030613.  Would one of the owners please
reopen this bug if it still exists in the latest build?  Thanks.

Comment 20

16 years ago
Still exists in Build ID: 2003030613

Comment 21

16 years ago
ARG, pasted in the wrong build ID in my followup (comment #20) -- this bug still
exists in 2003030808; please reopen.
(Assignee)

Comment 22

16 years ago
Reopening
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 23

16 years ago
Ctrl-clicking does not show a contextual menu, but right-clicking does.  The
summary should be changed to reflect this.
(Reporter)

Comment 24

15 years ago

*** This bug has been marked as a duplicate of 192276 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.