Closed Bug 192276 Opened 17 years ago Closed 15 years ago

"control click" on plugin brings up browser context menu

Categories

(Camino Graveyard :: Plug-ins, defect, P2, major)

PowerPC
macOS

Tracking

(Not tracked)

RESOLVED FIXED
Camino0.9

People

(Reporter: tracy, Assigned: sfraser_bugs)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

seen with recent chimera builds

-open a page with a flash animation
-control click the animation

tested results: the browser context menu appears

expected results: the flash context menu should appear.

I back tested this and discovered that this regressed between the builds for
2003-01-27-07(works) and 2003-01-28-07(broken since this build)
Also occurs with embedded QT movies. Tested under 10.1.5 and 10.2.3.

http://www.apple.com/switch/ads/tonyhawk.html
Severity: major → critical
Same problem with Real content too. No plugin contextual menu when using control
click:

http://www.weather.com/activities/verticalvideo/vdaily/weekendoutlook.html?from=nchomepage
generalizing the summary. could this be a recent regression?
Summary: "control click" on Flash animation brings up browser Context Menu → "control click" on plugin brings up browser context menu
duh, twalker already provides the regression data.
Keywords: regression
Taking. Note that a right-click with a two-button mouse works, but a
control-clickk doesn't.
Assignee: peterlubczynski → sfraser
well, we have no plugin-specific context menu. before my change, we'd show
nothing. now we always show a context menu. i think that's perfectly valid. so
is this bug that we show something at all, or we show the default document
context menu. If it's the latter, I'd vote future.
You can't tell if you have a plugin-specific context menu. The control-click has
to get down to the plugin, which displays the menu when handling the event.
Status: NEW → ASSIGNED
*** Bug 158345 has been marked as a duplicate of this bug. ***
This problem really needs to get fixed since it's affects people with a single
mouse button or a ibook/powerbook user using their trackpad (like me)...
still true with 2003090102 on 10.2.6
Nomimating this issue for 0.8. This is a pain for a powerbook/ibook user
attempting to use the trackpad display the plugin's contextual menu.
Target Milestone: --- → Camino0.8
Still true 20040319 NB.
I don't know if the following is related to this bug, because it is in a
different context. However, the effect is the same.
Camino draws the browser context menu even when it has been disabled with
JavaScript (for example, to implement my own context menu). 

Here is a test case (control- or right-click on the text "CHAPTER EXAMPLE")
http://www.yellowspace.net/camino_tests/cm.html

Here is a screenshot of what I see:
http://www.yellowspace.net/camino_tests/cm_shot.png

The same page works fine with recent (release 0.8/1.6 and nighties) od FireFox
and Mozilla, Mac and Win alike.

Happens on Camino 2004051308 (v0.8b) and "below".

Target Milestone: Camino0.8 → Camino1.0
Note that right-click works, but control-click doesn't.
See also the similar bug 242906 for general misbehavior with CMs on OBJECTs and
EMBEDs.
Priority: -- → P2
Severity: critical → major
Target Milestone: Camino1.0 → Camino0.9
*** Bug 298458 has been marked as a duplicate of this bug. ***
Comment on attachment 190372 [details] [diff] [review]
Patch: return nil from menuForEvent for plugin views

okies. r=pink
Attachment #190372 - Flags: review?(pinkerton) → review+
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.