Closed Bug 1584511 Opened 4 months ago Closed 2 months ago

[Wayland][WebRender] Toggling titlebar breaks remote content rendering for existing tabs

Categories

(Core :: Graphics: WebRender, defect, P3)

71 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox71 --- wontfix
firefox72 --- affected

People

(Reporter: ke5trel, Assigned: sotaro)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [keep-open])

Attachments

(2 files)

STR.

  1. Enable gfx.webrender.all and MOZ_ENABLE_WAYLAND=true on Ubuntu 19.04.
  2. Visit a website.
  3. Go into Customize and toggle the titlebar.

Content rendering breaks for existing tabs, shows permanent spinning wheel. New tabs unaffected.

Not a regression and reproducible back to Bug 1531300.

The priority flag is not set for this bug.
:jbonisteel, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jbonisteel)
Flags: needinfo?(jbonisteel) → needinfo?(sotaro.ikeda.g)
Priority: -- → P3

I could also reproduce the problem on Ubuntu 18.04 and on Ubuntu 19.04. When the titlebar was toggled, nsWindow::HideWaylandWindow() was called and CompositorSession was re-created. It caused the problem. To address the problem, WebRenderBridgeChild in child process needs to be re-created for new root WebRenderBridgeParent, since WebRenderBridgeParent::UpdateWebRender() does not work for this use case.

Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
Depends on: 1588987
No longer depends on: 1588987
Depends on: 1588987
Attached file Bug 1584511 - Backout
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c5c11d15147
Handle Compositor session recreation when egl_window is re-created r=stransky
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Regressions: 1590498
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [keep-open]
Attachment #9101467 - Attachment description: Bug 1584511 - Handle Compositor session recreation when egl_window is re-created → Bug 1584511 - Backout

The patch had 2 problems.

  • nsWindow::HideWaylandWindow() is called just during closing a window.
  • GPUProcessManager::Get()->ResetCompositors() updates all compositor. But it does not set "mCompositorInitiallyPaused = true" to all widget.
Target Milestone: mozilla72 → ---
Depends on: 1597619

On latest nightly, toggling titlebar does not work by Bug 1596709.

Depends on: 1596709
Depends on: 1597861

Bug 1542808 seemed to make the symptom worse.

The problem was addressed in latest nightly for me.

Great, thank you!

Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.