Closed Bug 1596709 Opened 29 days ago Closed 14 days ago

Toggling titlebar no longer shows/hides it for existing windows

Categories

(Firefox :: General, defect, P1)

72 Branch
Unspecified
All
defect

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + fixed

People

(Reporter: ke5trel, Assigned: bdahl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image Titlebar toggled on

STR:

  1. Go to Menu >> Customize.
  2. Toggle the Title Bar.

The titlebar fails to appear/disappear for current windows. New windows work as expected.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=038ebfdd141acdc7603d2378a832a572bb267686&tochange=9644ee96a51a03a8f4e50e9777fb7278f246383c

Regressed by Bug 1492582.

Attached image Titlebar toggled off
Duplicate of this bug: 1596708

[Tracking Requested - why for this release]: We cannot ship this.

Flags: needinfo?(bdahl)
Priority: -- → P1

The chromemargin attribute is also referenced in that file for <window> elements: https://searchfox.org/mozilla-central/rev/b58e44b74ef2b4a44bdfb4140c2565ac852504be/dom/xul/nsXULElement.cpp#763

Assignee: nobody → bdahl
Flags: needinfo?(bdahl)
Blocks: 1584511
Blocks: 1597861

Enables any type of document to use the special root element attributes
currently used by XUL <window>.

Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25246ff84740
Move special chrome root element handling to an observer. r=smaug
Status: NEW → RESOLVED
Closed: 22 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Regressions: 1598835

mozregression brings me here, because most of the UI on the latest FF build is not accessible with mouse. Only small part on the left can be used. Other than that clicking anywhere in the UI doing nothing.

Regressions: 1598848
Regressions: 1598859
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/4922e7294086
Backed out changeset 25246ff84740 as per Mossop req. a=backout
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

The bug caused a performances regression

== Change summary for alert #24129 (as of Mon, 25 Nov 2019 12:12:29 GMT) ==

Regressions:

76% raptor-tp6-facebook-firefox loadtime linux64-shippable-qr opt 414.96 -> 732.08
72% raptor-tp6-facebook-firefox loadtime linux64-shippable-qr opt condprof 416.33 -> 715.71
67% raptor-tp6-facebook-firefox loadtime linux64-shippable opt 408.85 -> 681.79
59% raptor-tp6-facebook-firefox loadtime linux64-shippable opt condprof 400.02 -> 638.00
16% raptor-tp6-facebook-firefox linux64-shippable-qr opt 311.16 -> 360.68
15% raptor-tp6-facebook-firefox linux64-shippable opt 301.08 -> 346.51
14% raptor-tp6-facebook-firefox linux64-shippable-qr opt condprof 311.15 -> 355.93
13% raptor-tp6-facebook-firefox linux64-shippable opt 301.54 -> 341.51
12% raptor-tp6-facebook-firefox linux64-shippable opt condprof 298.94 -> 334.86
6% raptor-tp6-tumblr-firefox-cold loadtime windows10-64-shippable-qr opt 1,625.50 -> 1,718.92
3% raptor-tp6-pinterest-firefox loadtime linux64-shippable-qr opt 951.75 -> 982.08
3% raptor-tp6-pinterest-firefox loadtime linux64-shippable opt 956.33 -> 981.42

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=24129

the back out returned things to normal
== Change summary for alert #24126 (as of Mon, 25 Nov 2019 06:25:51 GMT) ==

Improvements:

43% raptor-tp6-facebook-firefox loadtime linux64-shippable opt 699.88 -> 402.17
37% raptor-tp6-facebook-firefox loadtime linux64-shippable-qr opt condprof 668.71 -> 419.29
34% raptor-tp6-facebook-firefox loadtime linux64-shippable-qr opt condprof 694.58 -> 457.54
13% raptor-tp6-facebook-firefox linux64-shippable opt 343.84 -> 300.68
11% raptor-tp6-facebook-firefox linux64-shippable-qr opt condprof 350.86 -> 313.23
5% raptor-tp6-yahoo-mail-firefox fcp linux64-shippable opt 230.81 -> 219.12
5% raptor-tp6-yahoo-mail-firefox fcp linux64-shippable-qr opt 229.25 -> 218.92
3% raptor-tp6-pinterest-firefox loadtime linux64-shippable opt 981.71 -> 954.29

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=24126

Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/40b67d5f6d17
Move special chrome root element handling to an observer. r=smaug
Status: REOPENED → RESOLVED
Closed: 22 days ago17 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Input is broken again in current nightly version.

Backed out changeset 40b67d5f6d17 for causing Nightlies to not respond to clicks.

Backout link: https://hg.mozilla.org/mozilla-central/rev/0155d544ac6be808c97b112edbb6c05d690b6b4a

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 72 → ---
Regressions: 1600305
Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e3d873308197
Move special chrome root element handling to an observer. r=smaug
Status: REOPENED → RESOLVED
Closed: 17 days ago14 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: needinfo?(bdahl)
You need to log in before you can comment on or make changes to this bug.