Closed Bug 1584545 Opened 1 year ago Closed 1 year ago

Autocomplete and default action are different

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: verdi, Assigned: mak)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

I have a bookmark for my blog - https://michaelverdi.com/blog - and it's tagged with "blog." I was trying to go to the Mozilla blog and I typed "blog" into the address bar and it autocompleted to blog.mozilla.org but the first result (the default action) was my blog. So when I hit enter I was surprised to end up on my blog instead of the Mozilla blog.

My first thought is that we just shouldn't autocomplete in this situation.

See Also: → 1584606
Iteration: --- → 71.3 - Sept 30 - Oct 13
Points: --- → 3
Priority: -- → P1

The problem is the autofillPlaceholder we use to avoid flicker, we autofill on input, without knowing if the first result should be autofilled, and then we don't check back, when we actually receive it.

Keywords: regression
Regressed by: 1548031
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/b13503a2ce5f
Clear the autofill placeholder if the first result is not an autofill one. r=Standard8
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.