Closed Bug 1586250 Opened 5 months ago Closed 5 months ago

'Method not implemented' when calling method: [prplIAccount::unInit]

Categories

(Chat Core :: Yahoo! Messenger, defect)

defect
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird71 fixed)

RESOLVED FIXED
Instantbird 71
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird71 --- fixed

People

(Reporter: clokep, Assigned: clokep)

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review

If you have an old Yahoo or Facebook account, an error is thrown to the console when quitting:

JavaScript error: file:///Users/pcloke/mozilla/mozilla-central/obj-x86_64-apple-darwin18.7.0-tb/dist/Thunderbird%20Daily.app/Contents/Resources/components/imAccounts.js, line 786: NS_ERROR_NOT_IMPLEMENTED: Method not implemented'Method not implemented' when calling method: [prplIAccount::unInit]
JavaScript error: file:///Users/pcloke/mozilla/mozilla-central/obj-x86_64-apple-darwin18.7.0-tb/dist/Thunderbird%20Daily.app/Contents/Resources/components/imAccounts.js, line 786: NS_ERROR_NOT_IMPLEMENTED: Method not implemented'Method not implemented' when calling method: [prplIAccount::unInit]

The fix is easy, we just need to implement an unInit that does nothing.

Attachment #9098808 - Flags: review?(florian)
Assignee: nobody → clokep
Status: NEW → ASSIGNED

I also debated if it made sense to have an AbandonedAccount implementation for dead protocols, but it doesn't seem like much code would be shared between Facebook and Yahoo. The vast majority of the code is custom error messages.

Attachment #9098808 - Flags: review?(florian) → review+

Pushed by clokep@gmail.com:
https://hg.mozilla.org/comm-central/rev/1da5ee1ef0ea
'Method not implemented' when calling method: [prplIAccount::unInit]. r=florian

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 71

Hi Partrick, it would be good, if you could leave smaller patches for me to check in. M-C merges four times a day, so I need a patch for times a day. Currently Paul is not available and hence not producing patches, and Magnus is on PTO and hence also not producing patches or reviewing patches. Right now, for the merges in about two and seven hours I have nothing. This patch and the one from bug 1427205 would have served me very well for my sheriffing purposes.

Blocks: 1348534
No longer blocks: 1348534
Comment on attachment 9098808 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: Errors show up in the console if an old Facebook/Yahoo account exists.
Testing completed (on c-c, etc.): Has been on c-c for a while.
Risk to taking this patch (and alternatives if risky): I don't think there's much risk, this is adding an empty method.
Attachment #9098808 - Flags: approval-comm-esr68?
Attachment #9098808 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.