Closed Bug 1586254 Opened 5 months ago Closed 5 months ago

Perma browser/base/content/test/performance/browser_urlbar_search.js | unexpected changed rect: ({x1:0, x2:1279, y1:39, y2:199, w:1280, h:161}), window width: 1280

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 + verified

People

(Reporter: cbrindusan, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=4a4bf3a9e40d21b0cfc76aa34f62dcc6dda714d1&selectedJob=269763292

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269763292&repo=try&lineNumber=2063

[task 2019-10-04T11:21:54.956Z] 11:21:54 INFO - TEST-START | browser/base/content/test/performance/browser_urlbar_keyed_search.js
[task 2019-10-04T11:21:59.622Z] 11:21:59 INFO - TEST-INFO | started process screentopng
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - TEST-INFO | screentopng: exit 0
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - Buffered messages logged at 11:21:54
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - Entering test bound quantumbar
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - Buffered messages logged at 11:21:55
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - First opening
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-10-04T11:22:00.074Z] 11:22:00 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_quickRestart”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-10-04T11:22:00.075Z] 11:22:00 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-10-04T11:22:00.075Z] 11:22:00 INFO - Buffered messages logged at 11:21:59
[task 2019-10-04T11:22:00.075Z] 11:22:00 INFO - TEST-PASS | browser/base/content/test/performance/browser_urlbar_keyed_search.js | 0 unexpected reflows - true == true -
[task 2019-10-04T11:22:00.075Z] 11:22:00 INFO - comparing 23 frames
[task 2019-10-04T11:22:00.075Z] 11:22:00 INFO - Buffered messages finished
[task 2019-10-04T11:22:00.076Z] 11:22:00 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_urlbar_keyed_search.js | unexpected changed rect: ({x1:0, x2:1279, y1:46, y2:199, w:1280, h:154}), window width: 1280 -

Dão, this seems to be caused by the changes in Bug 1578375, could you please take a look at it?

Flags: needinfo?(dao+bmo)
Blocks: megabar
Component: General → Address Bar
Priority: -- → P2
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 71.3 - Sept 30 - Oct 13
Flags: needinfo?(dao+bmo)
Blocks: 1586520
Priority: P2 → P1

Regressed by bug 1584281, fails on beta now after that bug got uplifted.

Regressed by: 1584281
No longer regressed by: 1578375
Summary: Perma browser/base/content/test/performance/browser_urlbar_search.js | unexpected changed rect: ({x1:0, x2:1279, y1:39, y2:199, w:1280, h:161}), window width: 1280 - when Gecko 71 merges to Beta on 2019-10-14 → Perma browser/base/content/test/performance/browser_urlbar_search.js | unexpected changed rect: ({x1:0, x2:1279, y1:39, y2:199, w:1280, h:161}), window width: 1280
Points: --- → 2
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f693d9efd28f
Make sure runUrlbarTest doesn't complain about 'unexpected changed rect' in the non-megabar results panel. r=mak
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

This is occurring on mozilla-beta, can it be uplifted?

Flags: needinfo?(dao+bmo)
Duplicate of this bug: 1587594
You need to log in before you can comment on or make changes to this bug.