Closed Bug 1586671 Opened 2 months ago Closed 2 months ago

Broken profile creation in about:profiles

Categories

(Toolkit :: Startup and Profile System, defect)

71 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox71 + verified
firefox72 --- verified

People

(Reporter: flod, Assigned: kmag)

References

Details

Attachments

(1 file)

It looks like bug 1583114 didn't really fix the whole thing.

Create a new profile from about:profiles, at the end the profile won't show up in the list, and the console reports

TypeError: window.opener.CreateProfile is not a function createProfileWizard.js:260:19
    onFinish chrome://mozapps/content/profile/createProfileWizard.js:260
    _fireEvent chrome://global/content/elements/wizard.js:430
    advance chrome://global/content/elements/wizard.js:306
    listeners chrome://global/content/elements/wizard.js:474
    createProfileWizard chrome://global/content/aboutProfiles.js:211

If you refresh the page, the profile will show up, but if you try to start it, it won't work, given that nothing was actually written in profiles.ini

The way the create profile wizard calls a function on its opener is pretty ugly. If it makes things easier we could figure out a way to clean up the code and not do that.

Duplicate of this bug: 1587449
Attachment #9099919 - Attachment description: Bug 1586671: Pass opener as openDialog argument to profile creation wizard. r=Mossop → Bug 1586671: Pass opener as openDialog argument to profile creation wizard. r=mossop
Attachment #9099919 - Attachment description: Bug 1586671: Pass opener as openDialog argument to profile creation wizard. r=mossop → Bug 1586671: Pass callbacks as openDialog argument to profile creation wizard rather than using window.opener. r=mossop
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f33ba9f39ad0
Pass callbacks as openDialog argument to profile creation wizard rather than using window.opener. r=mossop
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → kmaglione+bmo
Flags: qe-verify+

Managed to reproduce this issue on 71.0a1(buildID:20191007215350).

Confirming this issue as verified fixed on 71.0b7(buildID:20191104135555) and 72.0a1 (buildID:20191104214406). Verified using Windows 10x64, Ubuntu 18.04 and macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.