ctrl+shift+L and other shortcuts don't work in new tab if Navigation Toolbar is turned off

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: dzy, Assigned: aaronlev)

Tracking

(Blocks: 1 bug)

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    

new tab doesn't get keyboard focus

Reproducible: Always
Steps to Reproduce:
1.ctrl-t to open a new tab
2.ctrl-shift-l to open url
3.

Actual Results:  nothing

Expected Results:  open url dialog popup

Comment 1

17 years ago
WFM 2002072204 trunk / Windows XP.

Comment 2

17 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020722

Comment 3

17 years ago
wfm 2002072204 linux (1.1b release).

Comment 4

17 years ago
WFM 2002072204 Win2k
but see also bug 153681
(Reporter)

Comment 5

17 years ago
will it still work if you turn off navigation toolbar?
WFM on WinXP trunk build 2002072308.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
somehow it would only work when the navigation toolbar is on on my box.

Comment 8

17 years ago
observations on 2002072204 linux:

- Navigation Toolbar -> Off
- Ctrl-t
- Ctrl-Shift-l
==> dialog does not open (doesn't seem to respond other hotkeys like ctrl-n,
ctrl-w... either)

- Navigation Toolbar -> Off
- Ctrl-t
- Click on content area
- Ctrl-Shift-l
==> dialog opens

- Navigation Toolbar -> On
==> works fine
Status: RESOLVED → UNCONFIRMED
OS: Windows XP → All
Resolution: WORKSFORME → ---
Summary: new tab doesn't get keyboard focus → new tab doesn't get keyboard focus if "Navigation Toolbar" is turned off

Comment 9

16 years ago
WFM with 2002103104/trunk/win2k.

reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 10

16 years ago
on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

test 1
with navigation toolbar off
1) ctrl - t
2) ctrl - shift - l and nothing happens

test 2
with navigation toolbar off
1) ctrl - t
2) click inside the new tab
3) ctrl - shift - l opens "open web location" dialog

test 3
with navigation toolbar on
1) ctrl - t
2) ctrl - shift - l and the dialog opens as expected

Comment 11

16 years ago
ok, confirming with 2002120108/trunk/win2k, now I understand the exact steps to
reproduce.

I guess keyboard navigation is a better place for this, but not sure without
knowing the cause..
Assignee: sgehani → aaronl
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: XP Apps → Keyboard Navigation
Ever confirmed: true
QA Contact: paw → sairuh
Summary: new tab doesn't get keyboard focus if "Navigation Toolbar" is turned off → ctrl+shift+L doesn't work in new tab if Navigation Toolbar is turned off
(Assignee)

Comment 12

16 years ago
This key is defined in navigatorOverlay.xul. So is Ctrl+P for Print, which also
doesn't work after a Ctrl+T. Seems like it might be a focus issue. I don't know
where the focus is when a new tab is opened and the nav toolbar is hidden.
Blocks: 83552
Summary: ctrl+shift+L doesn't work in new tab if Navigation Toolbar is turned off → ctrl+shift+L and other shortcuts don't work in new tab if Navigation Toolbar is turned off

Comment 13

16 years ago
This is still a problem for Windows / Mozilla 1.3a

( see bug 186906 )

Comment 14

16 years ago
*** Bug 186906 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
In Mozilla 1.0.2 is a little difference with this problem

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216 (Build
ID: 2002121606)

1) Close Navigation ToolBar
2) Ctrl+t -> new tab
3) Ctrl+Shift+l works fine for the first but, but if you 'Open Web Location'
dialog by Esc, so for second time Ctrl+Shift+l does not work.
4) After clicking inside blank page Ctrl+Shift+l start working forever in this tab

The same behavior is also with shortcut Ctrl+P and maybe other.

Comment 16

16 years ago
Please excuse my typing errors.
Item 3) should be:
Ctrl+Shift+l works fine for the first time, but if you dismiss 'Open Web Location'
dialog by Esc, so for the second time Ctrl+Shift+l does not work.

Comment 17

16 years ago
Problem reported in Comment #16  works for me 
for
Build 2003021008 (1.3 beta) on Windows (2000)  

Comment 18

15 years ago
This bug worksforme with Windows Seamonkey builds 2004020909
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.