Closed Bug 1588086 Opened 10 months ago Closed 10 months ago

Profiler not reading android symbols

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: jnicol, Assigned: gregtatum)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The about:debugging profiler, connected via USB to an android device, is not reading the symbols from my local android build properly. I have correctly added the objdir to the local build section.

I used mozregression on the desktop version of firefox, and found this regression range: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6baef669e147828062e93a6e7edec259853e7304&tochange=f44e632769d75b428d0a84a3274bdf45095b91fc (bug 1581975 presumably)

This is on Linux, and I'm profiling a local build of geckoview_example. The phone is a Pixel 2 running android 9. I think it also affects non-local builds too, because I originally tried to use mozregression on geckoview_example rather than the desktop browser, but even old versions of that (along with an up to date nightly on desktop) didn't show symbols

Flags: needinfo?(gtatum)

The function had the wrong argument parameters, and it wasn't
fetching the latest list of objdirs.

Hey jnicol, could you please try the patch locally and see if this fixes the problem for you? If yes I'll land it before Greg comes back from PTO to unblock you.

Flags: needinfo?(gtatum) → needinfo?(jnicol)

Hi Julien, I can confirm the patch fixes the problem.

Thanks both of you!

Flags: needinfo?(jnicol)
Pushed by jwajsberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc722de484d5
Fix the multi-modal getSymbolTable; r=julienw
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Assignee: nobody → gtatum
You need to log in before you can comment on or make changes to this bug.