Closed Bug 1588295 Opened 10 months ago Closed 10 months ago

Permafailing devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js | xpcshell return code: 0 on OS X when Gecko 71 merges to Beta on 2019-10-14

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

x86_64
macOS
defect

Tracking

(firefox-esr68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71+ fixed, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed
firefox72 --- verified

People

(Reporter: nataliaCs, Assigned: gregtatum)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:
Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=477249b7e818ab13006b360651725359cf410ab3&searchStr=xpcshell-e10s-1%2Cx%28x1%29&selectedJob=270999264

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=270999264&repo=try&lineNumber=4344

[task 2019-10-12T12:03:23.947Z] 12:03:23 INFO - TEST-START | devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js
[task 2019-10-12T12:03:24.228Z] 12:03:24 WARNING - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js | xpcshell return code: 0
[task 2019-10-12T12:03:24.228Z] 12:03:24 INFO - TEST-INFO took 268ms
[task 2019-10-12T12:03:24.228Z] 12:03:24 INFO - >>>>>>>
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.229Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2632
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-10-12T12:03:24.230Z] 12:03:24 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - running event loop
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js | Starting test
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - (xpcshell/head.js) | test test pending (2)
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - "Test that we get the default values from state."
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - PID 3737 | [3737, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - TEST-PASS | devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js | test - [test : 24] The initial state has the default buffersize. - "undefined" == "undefined"
[task 2019-10-12T12:03:24.231Z] 12:03:24 WARNING - TEST-UNEXPECTED-FAIL | devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js | test - [test : 29] The stackwalk feature is initialized to the default. - false == true
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/tests/devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js:test:29
[task 2019-10-12T12:03:24.231Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:run_next_test/_run_next_test/<:1565
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:_run_next_test:1565
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:run:733
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:_do_main:246
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - /Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:_execute_test:573
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - -e:null:1
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - exiting test
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - Unexpected exception NS_ERROR_ABORT:
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - _abort_failed_test@/Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:789:20
[task 2019-10-12T12:03:24.232Z] 12:03:24 INFO - do_report_result@/Users/cltbld/tasks/task_1570870764/build/tests/xpcshell/head.js:890:5

:Greg is there any chance you could take a look? Thank you

Flags: needinfo?(gtatum)

Based on https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=477249b7e818ab13006b360651725359cf410ab3&searchStr=xpcshell-e10s-1%2Cx%28x1%29&selectedJob=270999264 it seems only macOS is affected.

Could it be the same issue as I had in bug 1583868 comment 2? (i.e., stack walking is disabled on macOS non-Nightly.)

OS: Unspecified → macOS
Priority: -- → P1
Hardware: Unspecified → x86_64
Assignee: nobody → gtatum
Flags: needinfo?(gtatum)

This test is relying on a profiler feature that is not available in every
platform. This patch changes it to use the "js" feature, which should be
supported everywhere.

This patch should fix it, but this test is covering a Nightly-only feature, so the impact for Beta is negligible.

When trying to import this for the recent beta sims I get hunks failed I believe because of bug 1589122.

Hunk #1 FAILED at 26
1 out of 3 hunks FAILED -- saving rejects to file devtools/client/performance-new/test/xpcshell/test_popup_initial_state.js.rej

Flags: needinfo?(gtatum)
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b5c158150f9
Change popup test to use the js feature rather than stackwalk; r=gerald
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Just noting that I'm getting a lot of " WARNING: 'result.isErr()', file ... StartupCache.cpp, line 173" on macOS Catalina when I do:

./mach mochitest any/path/tosome/test.html

Not sure if it's happening for others, but it means that Mochitests are unusable (locally) because it's not possible to see the results. The whole thing just halts and no test results are recorded.

Flags: needinfo?(gtatum)

Comment on attachment 9103016 [details]
Bug 1588295 - Change popup test to use the js feature rather than stackwalk; r?gerald

Beta/Release Uplift Approval Request

  • User impact if declined: none
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): These are only test changes
  • String changes made/needed: none
Attachment #9103016 - Flags: approval-mozilla-beta?
Flags: needinfo?(gtatum)

Comment on attachment 9103016 [details]
Bug 1588295 - Change popup test to use the js feature rather than stackwalk; r?gerald

Low risk test updates, uplift approved for 71 beta 6, thanks.

Attachment #9103016 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.