Closed Bug 1588464 Opened 4 months ago Closed 4 months ago

First bookmark search result in address bar flickers while typing

Categories

(Firefox :: Address Bar, defect, P2)

71 Branch
defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.4 - Oct 14 - 20
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: ke5trel, Assigned: mak)

References

(Blocks 1 open bug, Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Make sure browser.search.separatePrivateDefault.ui.enabled = true.
  2. Focus address bar and type addons mozilla firefox addon nightly tester tools (corresponds with a default bookmark) while watching the first bookmark result.

The first bookmark often flickers when a key is pressed.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6eec85211514c69e54c7b8dd715998d0414950ce&tochange=fbf1a77926c2d27e71b69ec7d3509953c1627545

Regressed by Bug 1580834.

This seems to be the fact that we're getting (all?) search suggestions first, then the results from history. Hopefully Marco will have some ideas here...

Priority: -- → P2

The only idea I have so far is to add a delay to the search in a private window result... it's not a simple problem to solve in general, we get search results first, we add the search in pb, then other results arrive and we discover it should not be shown, thus it gets removed.

Assignee: nobody → mak77
Status: NEW → ASSIGNED
Iteration: --- → 71.4 - Oct 14 - 20
Points: --- → 3
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/c5bff62e1640
Add a delay to Search in a private window to reduce flicker. r=Standard8

Backed out 2 changesets (Bug 1588469, Bug 1588464) for causing bc failures in browser_test_focus_urlbar.js

Changeset c5bff62e1640 was backed out because I was getting a conflict while trying to backout the culprit from Bug 1588469 as these two are working on the same files.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/a3a8917a857f
Add a delay to Search in a private window to reduce flicker. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1589838
You need to log in before you can comment on or make changes to this bug.