Closed Bug 1589225 Opened 2 years ago Closed 2 years ago

Allow removing of "What's New" button

Categories

(Firefox :: Messaging System, enhancement)

71 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1599138
Tracking Status
firefox70 --- affected
firefox71 --- affected

People

(Reporter: greenreaper, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

I started Firefox Developer edition 71.0b1 and a strange new icon appeared: 🎁

I fear changes and I do not want to learn about them, plus the present icon looks suspicious (browsers bearing GIFs? Maybe a virus-laden extension has been loaded onto my browser?). I tried to remove it without opening it by right-clicking (well, long-pressing - this was on a Surface Pro; but it's not specifically a tablet issue) and selecting "Remove from Toolbar", which works for everything else.

Actual results:

The "Remove from Toolbar" option was disabled (as was "Pin to Overflow Menu").

When I tried to remove it via Customize instead, I found a potential Firefox Account button (which I duly removed - I don't want another account) next to the menu icon; but no What's New button to remove, even during the time it was there.

I eventually tappet it to open it and dismissed it. But I fear it will return! 🙀

Expected results:

Removing the icon without opening it should have been possible; and either way it should also have been possible to set the preference not to notify the user of changes at the same time. But there doesn't seem to be a UI for this at all.

Right now it seems you have to know browser.messaging-system.whatsNewPanel.enabled exists by reading bug 1561307, bug 1563319, or this random Reddit post (which demonstrates I'm not the only person to fear change): https://www.reddit.com/r/firefox/comments/dh4c80/how_to_disable_the_whats_new_icon/

P.S. Not sure if this counts as a defect or an enhancement. I think "being able to easily turn this off without knowing undocumented prefs" seems like a defect (or at least, the seeming lack of documentation), but you might have to add stuff to make it work, which seems like an enhancement.

Adding a few people who I think are relevant to this, feel free to remove yourself if that's inappropriate.

Blocks: 1561009
Component: Untriaged → Messaging System

On balance, more a defect than an enhancement, since "Shipping software is not behaving as expected" - by me as an end-user, anyway. If it's a toolbar button, it should behave like other buttons and be removable (even if that works by setting a pref); maybe have location customizable too.

This was a product decision to add "what's new." That team would have to consider the request.

Flags: needinfo?(tspurway)

The question/bug is not whether a "what's new" button is useful - I'm sure it is to some people. The bug is that it can't be customized, i.e. removed from the toolbar, just like all other buttons.

My first reaction was also to open customize to quickly get rid of it, only to find out this doesn't work.

Status: UNCONFIRMED → NEW
Ever confirmed: true

All the icons in the Customize view are always shown when placed in the toolbar. The What's New icon is conditionally shown like some of the icons in the address bar, e.g., bookmark, save to pocket, reader view; and those can't be customized.

I believe not allowing the moving of the icon was intentional as it's associated with the Firefox Menu, which is where the icon goes after clicking on it once.

Aaron, should we expose the icon as part of Customize or somehow else to remove it (and prevent it from showing up in the toolbar next release)? There is a context menu on other toolbar icons to "Remove from Toolbar" which I suppose we could support maybe without introducing the complexity of allowing it to be moved anywhere in the toolbar ?

Type: defect → enhancement
Flags: needinfo?(tspurway) → needinfo?(abenson)
Summary: No UI to disable "What's New" button; "Remove from Toolbar" disabled → Allow removing of "What's New" button

(In reply to Ed Lee :Mardak from comment #5)

All the icons in the Customize view are always shown when placed in the toolbar. The What's New icon is conditionally shown like some of the icons in the address bar, e.g., bookmark, save to pocket, reader view; and those can't be customized.

Are they always shown? The download icon has an option to auto-hide it when it's not relevant.

And the Pocket icon has a context menu with “Remove from Address Bar” as the one item, so it can be customized to some extent (not the same way as the normal toolbar icons, but discoverable enough).

(I'm speaking only as a user here; I don't know the internals of the browser frontend code.)

Attached image download icon menu

Oh neat, indeed the download icon has some special additional menu items. Maybe the what's new icon can be similar. Let users choose to not auto-hide as well.

Duplicate of this bug: 1591928
Blocks: whats-new-panel
No longer blocks: 1561009

The What's New item in the toolbar is not part of customize mode since it appears directly adjacent to the Application Menu however we will add a preference for disabling notifications as part of general product notification settings.

Flags: needinfo?(abenson)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1599138
You need to log in before you can comment on or make changes to this bug.