Closed Bug 1590077 Opened 10 months ago Closed 4 months ago

eyenewton.ru contact button broken by FIngerprinting blocking and TP

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- affected
firefox70 --- affected
firefox71 --- affected

People

(Reporter: oana.botisan, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image contact button.png

Affected versions

  • Firefox 71.a01
  • Firefox 70.0
  • Firefox 69.0

Affected platforms

  • Windows 10 x64

Prerequisites

  • Make sure that the Fingerprinters are blocked in about:preferences#privacy.

Steps to reproduce

  1. Go to https://zagorod.ru/.
  2. Observe the page.

Expected result

  • The button for contacts is displayed on the lower right section of the page.

Actual result

  • The button is missing.

Regression range

  • This is not a regression.

This is caused by us blocking eyenewton.ru. Specifically, we block:

  • https://eyenewton.ru/scripts/sda.min.js
  • https://eyenewton.ru/scripts/callback.min.js
  • https://eyenewton.ru/scripts/callback.min.js

Clicking this contact button opens a panel that appears to be the site's "contact us" page (from what I could gather through Google translate).

Blocks: tp-breakage
Summary: Missing contact button on https://zagorod.ru/ → eyenetwon.ru contact button missing on https://zagorod.ru/ when FIngerprinting blocking and TP are enabled
Duplicate of this bug: 1590118
Duplicate of this bug: 1592943

The fingerprinting script responsible here is https://eyenewton.ru/scripts/callback.min.js. Blocking only this script still breaks the experience.

Updating title to reflect that we can use this bug as the general bug to track issues with this domain.

Summary: eyenetwon.ru contact button missing on https://zagorod.ru/ when FIngerprinting blocking and TP are enabled → eyenetwon.ru contact button broken by FIngerprinting blocking and TP

stpeter would you mind to provide an update on your outreach efforts? Adding a ni as a reminder.

Flags: needinfo?(stpeter)

I reached out on 2019-12-04 and received an automated reply in Russian, but no further follow-up from Eyenewton since then. I'll try to find another route in via other partners in Russia.

Flags: needinfo?(stpeter)
Summary: eyenetwon.ru contact button broken by FIngerprinting blocking and TP → eyenewton.ru contact button broken by FIngerprinting blocking and TP
Priority: -- → P3

After exhausting our outreach efforts we've decided to accept this breakage for the fingerprinting protection feature. I'll keep the bug open and blocking the tracking protection feature since that is still broken.

No longer blocks: fp-blocking-breakage

The button is appearing (and seems to work) for me in strict mode now (also custom mode with fingerprinting protection on).

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME

(In reply to Thomas Wisniewski [:twisniewski] from comment #9)

The button is appearing (and seems to work) for me in strict mode now (also custom mode with fingerprinting protection on).

Thanks for the report!

You need to log in before you can comment on or make changes to this bug.