Sqare root gives crashes with only Mathematica fonts

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: sieboerg, Assigned: rbs)

Tracking

({crash, stackwanted})

Trunk
PowerPC
Mac System 8.5
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; de-AT; rv:1.1b) Gecko/20020722
BuildID:    2002072203

If there are Mathematica fonts installed but no TeX fonts (no free distribution
available for Mac) pages with square roots in formulas make  Moz crash. Easy
pages like  
http://www.w3.org/Math/testsuite/testsuite/General/GenAttribs/style2.xml
are shown incorrectly and freeze sometimes. Without Mathematica fonts, the sqare
roots are displyed incorrect, of course, but do not cause problems.

Reproducible: Always
Steps to Reproduce:
1. Download Mathematica fonts at 
http://support.wolfram.com/mathematica/systems/macintosh/general/MathFonts_TrueType.sea.hqx

2. Unpack and drag to system folter
3. Restart Mozilla

Comment 1

16 years ago
Dieter, can you produce a stack trace ?
Severity: normal → critical
Keywords: crash, stackwanted
Summary: Sqare root gives crashes with only Mathematica fonts → Sqare root gives crashes with only Mathematica fonts

Comment 2

16 years ago
perhaps related to checkin for bug 27860 ?
(Reporter)

Comment 3

16 years ago
> perhaps related to checkin for bug 27860 ?
I don't think so. Without Mathematica and TeX fonts, the x-length of the bar of
root sign seems to be correct, although its thickness and v-adjustment is
incorrect. I assume whithout the fonts the thick bar means missing
"character/font", but stretches correctly. 

> ------- Additional Comments From cahagn_o@epita.fr  2002-07-24 03:12 -------
> Dieter, can you produce a stack trace ?
Sorry, I don't have any compiler. Or can that be done with the browser's debug menu?

Dieter
(Assignee)

Comment 4

16 years ago
This bug is premature. Wait until bug 107146 is fixed.

Comment 5

16 years ago
Dieter, bug 107146 is now fixed. Can you download a recent nightly build and test if you can 
still reproduce this problem?

Mozilla will generate TalkBack reports following crashes. Does this ever happen in your 
experience? Do you have TalkBack enabled? If so, please let us know at least one of the report 
ID numbers that are generated.
Depends on: 107146
(Assignee)

Updated

16 years ago
No longer depends on: 107146
(Reporter)

Comment 6

16 years ago
Fixed successfully in build 2002080508. 

Report ID numbers are TB9020175X or TB8591074K
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.