Closed Bug 1591462 Opened 4 months ago Closed 3 months ago

Refactor autofill mechanics into an Autofill API

Categories

(GeckoView :: General, task, P1)

All
Android

Tracking

(firefox71 wontfix, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: esawin, Assigned: esawin)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [geckoview:m1911])

Attachments

(6 files)

We should continue the work started in bug 1577003, which introduced AutofillDelegate, AutofillElement and AutofillSupport, by combining the different autofill elements into a more coherent Autofill API.

We should also look into simplifying and documenting some of the original implementations.

In this bug, we can start by moving autofill mechanics out of other modules into the Autofill module and by rewriting the Java parts into a more GV-idiomatic API.

Blocks: 1577005
Type: enhancement → task

Selecting for November sprint.

Priority: -- → P1
Whiteboard: [geckoview:m1911]
Attachment #9104262 - Attachment description: Bug 1591462 - [1.0] Move autofill mechanics into a dedicated child module. → Bug 1591462 - [1.1] Move autofill mechanics into a dedicated child module.
Attachment #9104263 - Attachment description: Bug 1591462 - [2.0] Combine autofill mechanics in Java API. → Bug 1591462 - [2.1] Combine autofill mechanics in Java API.
Attachment #9106345 - Attachment description: Bug 1591462 - [4.0] Disable LoginManager storage for GeckoView. → Bug 1591462 - [4.1] Disable LoginManager storage for GeckoView.
Attachment #9106345 - Attachment description: Bug 1591462 - [4.1] Disable LoginManager storage for GeckoView. → Bug 1591462 - [4.2] Disable LoginManager storage for GeckoView.

Depends on D51723

Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a31fae37440
[1.1] Move autofill mechanics into a dedicated child module. r=snorp
https://hg.mozilla.org/integration/autoland/rev/4617ad7f36d4
[2.1] Combine autofill mechanics in Java API. r=snorp,geckoview-reviewers,droeh
https://hg.mozilla.org/integration/autoland/rev/c6c5c9370ab0
[3.0] Adjust autofill tests to the new API and fix naming. r=geckoview-reviewers,snorp
https://hg.mozilla.org/integration/autoland/rev/300057f0ec79
[4.2] Disable LoginManager storage for GeckoView. r=MattN
https://hg.mozilla.org/integration/autoland/rev/d3163cbe3b00
[5.0] Update changelog.
Duplicate of this bug: 1591737
You need to log in before you can comment on or make changes to this bug.