Closed Bug 1591495 Opened 9 months ago Closed 8 months ago

Update thumbnailer tests to use modern primitives

Categories

(Firefox :: General, task, P2)

task

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

The thumbnailer tests use an old-school handrolled TestRunner thing with yield and generators, and a bunch of helpers that have been superceded by stuff in BrowserTestUtils.

This is blocking us from getting bug 1576911 landed, since those tests are failing because they're using those old flake-y primitives. We shouldn't update those old mechanisms, we should just wholesale more over to more modern primitives.

Blocks: 1592079

This test is race-y, and doesn't actually ensure that the migration has completed
before doing its checks.

When I modified the test to wait for the migration to complete, the test actually
failed. Which isn't great news.

The good news, however, is that the migration took place back in Firefox 21, and
so we can probably remove all of the migration code now.

I'm disabling the test for now, and filed bug 1592079 to remove the migration code
and test completely.

Significantly, we remove the TestRunner stuff since we have nice things like
add_task now.

Depends on D50850

Priority: -- → P2
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/14014646834b
Disable browser_thumbnails_storage_migrate3.js. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/567490296c0e
Update thumbnailer test utility functions. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/0a35639905ee
Update thumbnail tests to use more modern primitives, like add_task. r=Gijs
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Regressions: 1595130
Regressions: 1595135
Regressions: 1595292
Blocks: 1539947

This bug appears to have caused a regression - https://bugzilla.mozilla.org/show_bug.cgi?id=1604780

You need to log in before you can comment on or make changes to this bug.