Closed Bug 1591547 Opened 4 months ago Closed 3 months ago

Unable to access banking websites

Categories

(Firefox :: Untriaged, defect)

70 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Webcompat Priority ?

People

(Reporter: tedbenjeski, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I've used Firefox Quantum to access my multiple banking websites for years, without difficulty, most recently on 2019-10-11.

Actual results:

It appears that my Firefox Quantum (64-bit) has been updated to "Firefox Browser 7.0" (64-bit) sometime after 2019-10-11. Today, 2019-10-25, I'm unable to access my multiple banking websites - some, I'm able to log in but the web pages fail to populate - some, I'm unable to log in at all-nothing happens.

My troubleshooting efforts have been to downgrade the Browser Privacy settings, in case they were the root cause of my access difficulty, but there was no change. Cookies are enabled as well as popups, but still no change.

Expected results:

I switched to Chrome web browser and was immediately able to successfully log into my banking websites.

I prefer to use Firefox to access my banking websites - therefore, please advise what I can do to configure my Firefox Browser 7.0 (64-bit) web browser so that I can once again successfully access my banking websites.

Thank You!

We're looking at some similar issues. Could you attach a profile to this bug (go to about:support)? And also, are you running Kapersky.

Flags: needinfo?(tedbenjeski)

An easier first step than providing a profile would be to go to https://firefox-storage-test.glitch.me/ (note that the https is important; clicking on the link here in Bugzilla will work).

If things are fine with the profile, then we'd expect "Specific Subsystem Statuses" on the page to look like:

LocalStorage
    Good: Totally Working. (fullyOperational)
QuotaManager
    Good: Totally Working. (fullyOperational)
IndexedDB
    Good: Totally Working. (fullyOperational)
Cache API
    Good: Totally Working. (fullyOperational)

If, however, there's a problem with the profile's storage, we'd expect some failures in that list.

In the event there is a failure, opening about:support (which you'll need to type into the location bar or access via going to the menu icon, then "Help", then "Troubleshooting Information") and clicking on "Refresh Firefox..." in the gray box in the upper right should rectify the problem by copying over the important data in your profile and leaving the broken storage data behind.

Greetings, Emma and Andrew...

Thank you very much for your quick replies to my bug report!

To answer Emma's question, no I am not using Kapersky. My antivirus software is Avast.

I was about to go to support when Andrew's reply appeared, so I decided to select the https://firefox-storage-test.glitch.me that appears in his reply. As a result, the following text appeared:

Investigating...
If this doesn't go away, things are unexpectedly broken.

So, does this mean that I need to Refresh Firefox and this should fix this problem? I've used the Refresh Firefox previously, a number of years ago. What data/settings will I lose if I perform a Refresh Firefox now? Please advise. I don't want to lose stored passwords.

ADDITIONAL INFORMATION
I've second computer that also has Firefox web browser installed, and which was just updated from Firefox Quantum to Firefox Browser 7.0. I just attempted to access the Bank of America website and it appears to work, compared to the experience contained in my above bug report for the computer that I'm currently using to type this message to you. However, I've not performed a thorough test yet.

Q: If my Firefox web browser had a large number of open tabs that remained open during the update from Firefox Quantum to Firefox Browser 7.0, could the multiple open tabs corrupted the update process? Just a thought...

Flags: needinfo?(tedbenjeski)

Questions: Since my Firefox Browser 7.0 (64-bit) web browser appears to have failed the Firefox Storage Test (https://firefox-storage-test.glitch.me), would the use of the Refresh Firefox feature be sufficient to fix my Firefox Browser 7.0 (64-bit) web browser?

Given that my Firefox Browser 7.0 (64-bit) web browser had a large number of open tabs during the time that the update from Firefox Quantum to Firefox Browser 7.0 (64-bit), could this have corrupted the update process? If the update process from Firefox Quantum to Firefox Browser has been corrupted, would the use of the Refresh Firefox feature have the capability to repair the corrupted update process?

Questions: Since my Firefox Browser 7.0 (64-bit) web browser appears to have failed the Firefox Storage Test (https://firefox-storage-test.glitch.me), would the use of the Refresh Firefox feature be sufficient to fix my Firefox Browser 7.0 (64-bit) web browser?

Given that my Firefox Browser 7.0 (64-bit) web browser had a large number of open tabs during the time that the update from Firefox Quantum to Firefox Browser 7.0 (64-bit) occured, could this have corrupted the update process? If the update process from Firefox Quantum to Firefox Browser has been corrupted, would the use of the Refresh Firefox feature have the capability to repair the corrupted update process?

I'm investigating the issue and I'll send more information soon. https://firefox-storage-test.glitch.me reports "Investigating... If this doesn't go away, things are unexpectedly broken." because even LocalStorage database for that site seems to be corrupted and script.js doesn't handle that currently.
For now, you can can fallback to the old LocalStorage implementation by changing "dom.storage.next_gen" preference to "false".

Refresh Firefox should correct the problem. There's more info on the side effects of this at https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings you can read. For what :janv is referring to, if you open about:config you can search for the dom.storage.next_gen preference and toggle it.

Open tabs are unlikely to have caused the underlying corruption. Something in the past likely caused a corrupted write to a database. A computer crash or hardware problems would be the most likely explanation.

https://firefox-storage-test.glitch.me has been fixed, you can try it again and report back.

Greetings, Jan...

Here are the results of the https://firefox-storage-test.glitch.me test that I just performed.

===============

Overview:
Storage is broken. This is your first visit or all storage was automatically cleared.
Specific Subsystem Statuses:

LocalStorage
Bad: Our test logic is broken, please copy and paste the contents of 'Debug Info' below and anything in the devtools console and send to :asuth. (unexpectedBreakage)
QuotaManager
Bad: Totally Broken. (fullyBroken)
IndexedDB
Bad: Totally Broken. (fullyBroken)
Cache API
Bad: Totally Broken. (fullyBroken)

Debug Info:

storage.estimate() threw: The expression cannot be converted to return the specified type.
Failed to create "persistent" IDB.
Failed to create "transient" IDB.

{
"v": 1,
"curVersion": 70,
"prevVersion": 0,
"ls": {},
"qm": {
"lastWorkedIn": 0
},
"idb": {
"persistentCreatedIn": 0,
"persistentLastOpenedIn": 0,
"clearDetectedIn": 0
},
"cache": {
"firstCacheCreatedIn": 0,
"unpaddedOpaqueCreatedIn": 0,
"paddedOpaqueCreatedIn": 0
}
}

===============

Does the above information provide any insight as to the problem with my Firefox Browser 7.0 (64-bit) web browser?

FYI - I have three other computers that had Firefox Quantum installed and which were auto-updated with Firefox Browser 7.0 around the same time that my fourth computer (problem computer) experienced this same auto-update. I just performed the https://firefox-storage-test.glitch.me test on these three other computers and each of them passed with no problems found.

Ok, so according to the report from https://firefox-storage-test.glitch.me, there's a problem with your storage/ folder in Firefox profile. It's likely that the problem existed before you updated Firefox to version 70.0. You just didn't notice because LocalStorage didn't depend on QuotaManager.
We are going to disable new LocalStorage implementation until these problems are solved.

Greetings, Jan...

Thank you for your analysis of the problem and the information that the LocalStorage implementation will be disabled until these problems are solved.

According to my above report from https://firefox-storage-test.glitch.me, LocalStorage, QuotaManager, IndexedDB, and Cache API all reported as being "Bad/Totally Broken". What corrective action is required to fix this so that my Firefox Browser 70.0 (64-bit) is fully functional again? Do I have to wait until update version 70.1 has been released, or is there something that I can do to fix this?

FYI - I have begun to experience problems with other websites that I customarily access, in addition to the banking websites that I previously reported. Unfortunately, it appears that my Firebox Browser 70.0 is quickly becoming unusable as a reliable web browser, in its current condition.

Q: When will Firefox Browser 70.1 be released?

Hi TR,

Sorry for the delay. I leave you the link with the calendar: https://wiki.mozilla.org/Release_Management/Calendar.

Regards, Flor.

Hi TR,

I'll proceed to close this bug as WFM. If you still encounter this bug, let me know.

Regards, Flor.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.