Closed Bug 1591787 Opened 2 years ago Closed 1 year ago

Startup Crash in [@ atcuf32.dll | mozilla::Preferences::RegisterCallbackAndCall] involving BitDefender

Categories

(Thunderbird :: General, defect)

x86
Windows
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash, topcrash-thunderbird)

Crash Data

User Story

workaround: add Thunderbird.exe to Advanced Threat Defense exception list per https://forum.bitdefender.com/index.php?/topic/81641-latest-update-breaks-thunderbird/  

* https://support.mozilla.org/questions/1275787
* https://support.mozilla.org/questions/1275164
* https://support.mozilla.org/questions/1274953
* https://support.mozilla.org/questions/1271948

Startup crash.
Signature first appears 68.1.1 and 69.0b0.
Addon related??

This bug is for crash report bp-c4ff8bee-ef6e-4eb0-9707-c1c660191027.

Top 10 frames of crashing thread:

0 atcuf32.dll atcuf32.dll@0x2d8e 
1  @0x47b002a 
2 xul.dll mozilla::Preferences::RegisterCallbackAndCall modules/libpref/Preferences.cpp:5006
3 xul.dll XREMain::XRE_mainRun toolkit/xre/nsAppRunner.cpp:4512
4 xul.dll XREMain::XRE_main toolkit/xre/nsAppRunner.cpp:4750
5 xul.dll XRE_main toolkit/xre/nsAppRunner.cpp:4831
6 xul.dll mozilla::BootstrapImpl::XRE_main toolkit/xre/Bootstrap.cpp:45
7 thunderbird.exe NS_internal_main comm/mail/app/nsMailApp.cpp:291
8 thunderbird.exe wmain toolkit/xre/nsWindowsWMain.cpp:131
9 thunderbird.exe static int __scrt_common_main_seh f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:288

Firefox crashes are rare, and for old versions? bp-3adae57c-5d53-46ec-88ff-44f6b0191027

Flags: needinfo?(jorgk)

Some googling indicates that atcuf32.cll is "BitDefender Active Threat Control Usermode Filter", some kind of antivirus thing. All the crashes are on Windows. All but two of the Firefox crashes occurred in 64.0b6, which is an oddly version-specific result.

My best guess is that the BitDefender DLL is messing with Firefox/Thunderbird and causing the crash :(

Flags: needinfo?(n.nethercote)

aklotz: I know you don't work on DLL injection stuff any more, but can you comment on the plausibility of comment 2? Thanks!

Flags: needinfo?(aklotz)

Thanks, Nicholas. Should we put this onto the blocklist then?

I will defer to aklotz on that question.

IIRC, we tend not to blocklist unless the issue is pervasive. But in this case it is #5 crash for 68.2.0. That's a good reason to reach out to the vendor. Who would have a contact at bitdefender?

Some process details at https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/AMO/Blocking_Process

You can blocklist it, but you need to show evidence that blocking the DLL doesn't break anything; ie. you need to reproduce the issue, then re-test once you've added to the blocklist to ensure that both the crashes are gone and that everything still runs.

Flags: needinfo?(aklotz)

So to repeat - what contacts to we (Mozilla or Thunderbird) have at bitdefender ?
And if present company doesn't know, then who at Mozilla would know?

Flags: needinfo?(aklotz)
OS: Windows 10 → Windows
Summary: Startup Crash in [@ atcuf32.dll | mozilla::Preferences::RegisterCallbackAndCall] → Startup Crash in [@ atcuf32.dll | mozilla::Preferences::RegisterCallbackAndCall] involving BitDefender

(In reply to Wayne Mery (:wsmwk) from comment #8)

So to repeat - what contacts to we (Mozilla or Thunderbird) have at bitdefender ?
And if present company doesn't know, then who at Mozilla would know?

Chat with Peter Dolanski or Romain Testard.

Flags: needinfo?(aklotz)

sfhowes in https://support.mozilla.org/en-US/questions/1274953#answer-1273391 states " I would start by disabling the option to scan incoming and outgoing email: https://www.bitdefender.com/consumer/support/answer/2092/ If you're not attached to Bitdefender, remove it and use Windows Defender, with the TB profile folder added as an Exclusion in WD settings."

User Story: (updated)

Experienced this crash with Thunderbird 68.3.1. I've found that just adding Thunderbird.exe to the exclusions in Bitdefender solves the problem and seems like the least intrusive workaround until a real fix is found.

Duplicate of this bug: 1607012

(In reply to Oliver Benais from comment #12)

Experienced this crash with Thunderbird 68.3.1. I've found that just adding Thunderbird.exe to the exclusions in Bitdefender solves the problem and seems like the least intrusive workaround until a real fix is found.

Oliver, can you produce and send to bitdefender the information requested at https://forum.bitdefender.com/index.php?/topic/81641-latest-update-breaks-thunderbird/&do=findComment&comment=293676

The exact workaround documented at https://forum.bitdefender.com/index.php?/topic/81641-latest-update-breaks-thunderbird/ is "add Thunderbird.exe to Advanced Threat Defense exception list"

I've tried to make contact with the vendor - no success yet.

User Story: (updated)

FWIW, crashes abruptly are almost gone from crash-stats as of Jan 15, down from 2k crashes per day.

Oliver shared additional information

  • supporttool.exe is there [in the free version], but when you run it you don't get the option to start logging, all you can do is go to the website to report your problem - kind of pointless here.
  • I had the crash and put in the exception with Thunderbird 68.3.1. But after updating to 68.4.1, I removed the exception and there was no longer any crash. Just in case, on the next PC, I verified that Thunderbird 68.3.1 still crashed before doing the update and no longer having a crash. Which tells me that whatever incompatibility there was between Thunderbird and Bitdefender was solved by a Thunderbird update, not a Bitdefender one.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.