Font help for User Defined

RESOLVED FIXED in seamonkey2.1a2

Status

SeaMonkey
Help Documentation
RESOLVED FIXED
15 years ago
7 years ago

People

(Reporter: timeless, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.6})

Trunk
seamonkey2.1a2
fixed-seamonkey2.0.6

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
steps:
edit>preferences>appearance>fonts
help

Ok, so most of us know or can figure out what Greek and Japanese are. But what
in the world is User Defined? Can I get a little help here?

Comment 1

15 years ago
not related, but setting 159253 dependency anyway

-> documentation
Blocks: 159253
Component: Help → User
Product: Browser → Documentation
QA Contact: tpreston → rudman
Version: Trunk → unspecified

Comment 2

15 years ago
*** Bug 96687 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
moving stuff over to an outside-the-firewall email for the time being, looking
for people to pick these Help and doc bugs up for me.
Assignee: oeschger → oeschger

Comment 4

14 years ago
--> me

Ian Oeschger doesn't work on mozilla anymore.

CC Nilson: Doc Bug ;)
Assignee: oeschger → rlk
QA Contact: rudman → stolenclover

Comment 5

14 years ago
I don't think I'm seeing this. Where is User Defined?
it's in edit/preferences/appearance/fonts, the dropdown list contains it

Comment 7

14 years ago
User Defined is for a special language encoding.
www.mozilla.org/docs/web-developer/faq.html reads:

> Downloadable fonts are usually used on sites using writing systems
> for which proper support has been missing in browsers in the past.
> These sites (for example some Indian sites) code the text in Latin
> gibberish and then use a font that to the browser and operating
> system seems to be a Latin font but has eg. Devanagari glyphs, so
> that when the Latin gibberish is rendered with the font it seems to
> a human reader to be intelligible text in some language. The same
> approach has been also been used for including Greek letters as
> math symbols in otherwise Latin-based text.

We could change the text:
 *Fonts for*: Choose a language character set. For instance, to set
 default fonts for the Western (Roman) character set, choose "Western."
+User Defined is reserved for any situation where character glyphs are
+not available in any character encoding and special fonts are required,
+for example, when a rare language or mathematics are used. Sites
+requiring special encoding should have instructions on what fonts to
+download and/or use.
(Reporter)

Comment 8

14 years ago
User Defined is reserved for any situation where character glyphs are
not available in any character encoding and special fonts are required,

"reserved" is wrong and "not available in any character encoding" is wrong.

sorry, if i had a good way to write this i'd have suggested it, it's a lot
easier to know what not to say than to know what to say.

Comment 9

14 years ago
Created attachment 135194 [details]
intl.html . split off from nav_help.xhtml

<p>User Defined is for any situation where character glyphs
[img: 日, A, æ, ら] are (or were) not in any character encoding
and special fonts are required, for example, when a rare language
or mathematics are used. Sites requiring special encoding should
have instructions on what fonts to download and/or use.</p>

Updated

13 years ago

Updated

13 years ago
Assignee: rlk → nobody

Updated

10 years ago
Component: Help Viewer → Help
Product: Documentation → Mozilla Application Suite
Version: unspecified → Trunk
Assignee: nobody → neil
(Assignee)

Comment 10

9 years ago
So "User Defined" in Edit > Preferences > Appearance > Fonts / "Fonts for" directly relates to View > Character Encoding > More Encodings > User Defined and neither is explained currently.

I suggest simply creating a link from "Fonts for" (heading "Appearance Preferences - Fonts") to heading "Selecting Character Encodings and Fonts" and explaining "User Defined" there, like this:

"Choose User Defined when the page you are viewing shows wrong character glyphs with all predefined character encodings. In that case you will need to specify the fonts required for correct rendering in the [link]Fonts preferences[/link]."

Comment 11

7 years ago
I am happy with this as a solution, is it worth mentioning something similar to the bit about "Sites requiring special encoding should have instructions on what fonts to download and/or use" (from comment 9) somewhere in there too?
Assignee: neil → nobody
OS: Windows 2000 → All
QA Contact: danielwang → help
Hardware: x86 → All
(Assignee)

Comment 12

7 years ago
Created attachment 445482 [details] [diff] [review]
patch v1

Comparing the menu item labels with the Help contents I found that some were referred to incorrectly in the text. Don't know since when but we can just as well correct them while we're here.

"Unicode" should be named explicitly because it's not obvious that it falls under "Other Languages" (BTW: in the German localization the menu entry is actually called "Unicode", making things easier).

I also wanted to take the opportunity to explain that the "Fonts for" drop-down selection actually determines the applicability of the set of font definitions below. This can be missed easily; it even took /me/ quite some time to get that connection (years ago).
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #445482 - Flags: review?(iann_bugzilla)

Comment 13

7 years ago
Comment on attachment 445482 [details] [diff] [review]
patch v1

>+    <q>Western.</q> For Unicode or a language/script not yet in the list, choose
>+    <q>Other Languages.</q> For more information, including <q>User Defined</q>,
>+    see <a href="nav_help.xhtml#selecting_character_encodings_and_fonts">Selecting
>+    Character Encodings and Fonts</a>.<br/>
>+    All settings below, except for the checkbox, are stored per language group
>+    you select here; each can have its own set of font definitions.
So we really need "you select here"? Just seems to confuse things to me.

>+++ b/suite/locales/en-US/chrome/common/help/nav_help.xhtml

>+<p>If the page you are viewing shows wrong character glyphs with all predefined
>+  character encodings there is a chance that it requires special fonts. Such
>+  sites should contain instructions on which fonts to download and/or use in
>+  order to view the page correctly. When you have the necessary fonts installed
>+  on your system you can choose User Defined from the More Encodings submenu.
>+  &brandShortName; will then use the fonts defined in the <a
>+  href="cs_nav_prefs_appearance.xhtml#fonts">Fonts preferences</a> (Fonts for:
>+  User Defined).</p>
We're missing some punctuation here, perhaps:
"If the page, which you are viewing, shows wrong character glyphs with all predefined  character encodings, there is a chance that it requires special fonts."
also:
"When you have the necessary fonts installed on your system, you can choose User Defined from the More Encodings submenu."
r=me with those issues addressed.
Attachment #445482 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 14

7 years ago
Created attachment 445832 [details] [diff] [review]
patch v1a, r=IanN [Checkin: comments 15+16]

(In reply to comment #13)
> (From update of attachment 445482 [details] [diff] [review])
> >+    All settings below, except for the checkbox, are stored per language group
> >+    you select here; each can have its own set of font definitions.
> So we really need "you select here"? Just seems to confuse things to me.

No, I was contemplating it, too.

> We're missing some punctuation here, perhaps:

OK, you had the better arguments on IRC. :-)
Attachment #445482 - Attachment is obsolete: true
Attachment #445832 - Flags: review+
Attachment #445832 - Flags: approval-seamonkey2.0.6?
(Assignee)

Comment 15

7 years ago
Comment on attachment 445832 [details] [diff] [review]
patch v1a, r=IanN [Checkin: comments 15+16]

http://hg.mozilla.org/comm-central/rev/f2e97ca98a85
Attachment #445832 - Attachment description: patch v1a, r=IanN → patch v1a, r=IanN [Checkin: comment 15]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a2

Updated

7 years ago
Attachment #445832 - Flags: approval-seamonkey2.0.6? → approval-seamonkey2.0.6+
(Assignee)

Comment 16

7 years ago
Comment on attachment 445832 [details] [diff] [review]
patch v1a, r=IanN [Checkin: comments 15+16]

http://hg.mozilla.org/releases/comm-1.9.1/rev/7db7182a402a
Attachment #445832 - Attachment description: patch v1a, r=IanN [Checkin: comment 15] → patch v1a, r=IanN [Checkin: comments 15+16]
(Assignee)

Updated

7 years ago
Keywords: fixed-seamonkey2.0.6
You need to log in before you can comment on or make changes to this bug.