user defined font sizes are not used.

RESOLVED DUPLICATE of bug 159254

Status

SeaMonkey
Preferences
RESOLVED DUPLICATE of bug 159254
17 years ago
13 years ago

People

(Reporter: Brad Lanam, Assigned: Samir Gehani)

Tracking

({intl})

Trunk
mozilla1.0.1
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME; Needs pref panel investigation, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.3) Gecko/20010808
BuildID:    2001080817

Solaris 8 - Mozilla 0.9.3 Xlib.

Set the user defined font size to 18.
Font displayed is very small.  This web page does not set the font
size at all.  It is the default font size.

Reproducible: Always
Steps to Reproduce:
1. Edit->Preferences->Appearance/Fonts
2. Select Fonts for: 'User Defined'
3. Select font size as 18.

Actual Results:  Font size displayed on web page did not change.

Expected Results:  Font size should have been much larger.
Setting View->Text Size->200% achieves the right size.
Component: XP Apps → Preferences
Whiteboard: DUPEME
Might be related to bug 95774. But I only have seen that bug with some
2001-08-17 builds.

Comment 2

17 years ago
I have encountered this problem on RedHat Linux 7.1 on the past few builds.  I 
have been struggling and straining my eyes with a small font-size since the past 
2 weeks. It is really annoying.

The user-defined preferences/font size does not change the browser font size. 
Latest build tested on is 2001-09-20-04-0.9.4 linux 7.1. 
Go to http://home.netscape.com 

Changing the bug status to NEW.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Two questions to bug reporter:

1. Do you have "Edit->Preferences->Appearance/Fonts/Allow document to use other
fonts" flag set or not? Probably yes, and document usess its own font settings?

2. Did you try to set View->Character Coding->More->UserDefined document
character coding?
(Reporter)

Comment 4

16 years ago
> 1. Do you have "Edit->Preferences->Appearance/Fonts/Allow document to use
> other fonts" flag set or not? Probably yes, and document usess its
> own font settings?

    No. Set off.  As stated above the document does not have *any* font
    settings.

> 2. Did you try to set View->Character Coding->More->UserDefined document
> character coding?

    Doing this displays the font in the proper size.

    I believe I switched to "User Defined" fonts because when "Western"
    is selected, there are two options for fonts, Serif and Sans-Serif.
    In addition, when "Western" is selected, there are no font size
    selections available.  If the font size selection had worked, I 
    would never had noticed this.

    I just discovered I can switch font sizes in "Western" by doing the
    following:  Switch to "User-Defined" fonts; select a new font size;
    Switch back to "Western".

    I would categorize this as a user-interface issue.  The label 
    "Fonts for" is correct -- the fonts selected are put into effect
    for the character encoding selected.   But the user is expecting
    the font/sizes to change when he changes the font/sizes.

    A couple of possible ways around this:

    (a) Automatically change the selected character encoding to the last
    selected "font for".  This could introduce other user-interface issues
    for people who actually switch between character encodings.  However,
    I would assume(!) that most people pick one character encoding and
    stay there.

    (b) Put the "view character encoding" selection on the fonts screen in
    addition to the menu.  Make sure the labels for "character encoding" and
    "fonts for" make it clear that the character encoding is what will be
    displayed, and the "fonts for" is a selection for a particular character
    encoding, and not what's currently being displayed.
 
(Reporter)

Comment 5

16 years ago
Every time I switch to another web page, the character
encoding switches back to "Western".  This other web page has
no encoding specifications, and no font specifications.

Comment 6

16 years ago
dup of bug 66182?

Comment 7

16 years ago
-> layout
Assignee: pchen → attinasi
Component: Preferences → Layout
QA Contact: sairuh → petersen

Comment 8

16 years ago
This is not a layout problem. If it were, then it would fail on all platforms.
It could either be a problem with the Font Pref dialog, or with the font
selection code I think. Over to Preferences first to make sure we have the UI
hooked up correctly.
Assignee: attinasi → sgehani
Component: Layout → Preferences
QA Contact: petersen → sairuh
(Assignee)

Comment 9

16 years ago
Madhur,
You said you saw this regression occur recently: could you please narrow it down
to two builds between which this problem first started?  Thanks.
(Assignee)

Updated

16 years ago
Whiteboard: DUPEME → DUPEME; Needs pref panel investigation
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0.1

Comment 10

16 years ago
FYI, the User-Defined font is meant to be used in conjunction with activating
"View -> Character Coding -> More -> UserDefined", and the character coding is
not persistent. So reading this bug, it seems to me that things are working as 
expected (no bug). Perhaps, the real problem is that activating the User-Defined 
font correctly is simply obscure and a few comments may need to be displayed 
when the user selects the User-Defined font.
Keywords: intl

Comment 11

16 years ago
Does this bug only happen on mozilla-browser based on Xlib, not on GTK+?

I tried on both broswers as the way of rbs@maths.uq.edu.au and found no 
problems, I have the same opinion with rbs@maths.uq.edu.au.

Updated

16 years ago
Depends on: 116651

Updated

16 years ago
No longer depends on: 116651

Comment 12

15 years ago
Marking as dup of bug 159254 which is about having a formal Help information
about the issue.

*** This bug has been marked as a duplicate of 159254 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.