Closed Bug 1592562 Opened 4 months ago Closed 4 months ago

Lockwise "about:logins" shows "No logins found" when e10s is disabled

Categories

(Firefox :: about:logins, defect, P2)

70 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- wontfix

People

(Reporter: hill-robert, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Environment: Firefox 70 on Windows 7 SP1 32-bit.
No addons/plugins except standard OpenH264 and Widevine.
About 40 stored logins/passwords; no master password; no Sync; no Firefox Account.
To reproduce problem: issue "about:logins".

Actual results:

"about:logins" shows "No logins found", even though about 40 logins exist.
Browser Console shows following error message every time "about:logins" issued:

Error: AboutLoginsParent: Received AboutLogins:Subscribe message the remote type didn't match expectations: null == privilegedabout ... AboutLoginsParent.jsm:195:13

In order to verify logins/passwords, set "signon.management.overrideURI" to empty, so that "Open menu" ... "Logins and Passwords" opens old-style "Saved Logins" window, which correctly shows all my logins (and passwords).

Does not look like Bug 1571555, because that was fixed in Firefox 70, plus the error message is different.

Does not look like Bug 1571401, because I do not use, and have never used, Sync.

Expected results:

"about:logins" should show logins (and passwords), and should not issue message:

Error: AboutLoginsParent: Received AboutLogins:Subscribe message the remote type didn't match expectations: null == privilegedabout ... AboutLoginsParent.jsm:195:13

Sorry, typo: the reference to Bug 1571401 should have been Bug 1591401.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → about:logins

Hi Bob, thanks for the report. Can you attach the data from about:support? Can you also list any non-default (bold) preferences in about:config matching the filter browser.tabs.remote. and dom.ipc.?

Flags: needinfo?(hill-robert)
Priority: -- → P1
Attached file about-support.txt

Hi Matthew, Thank you for your quick response. Please see attached file "about-support.txt".
In about:config, both with filter "browser.tabs.remote.", and also with filter "dom.ipc.", there are no bold (non-default) preferences at all.

Flags: needinfo?(hill-robert)

Hmm… the problem seems to be related to:

Multiprocess Windows: 0/1 Disabled forcibly

…since we load about:logins in its own process. Have you forcibly disabled e10s/multi-process somehow? Maybe with an environment variable?

Flags: needinfo?(hill-robert)
Summary: Lockwise "about:logins" shows "No logins found" → Lockwise "about:logins" shows "No logins found" when e10s is disabled

Hi Matthew, Thank you again for your quick response.

Yes, since Firefox 68 I forcibly disable multi-process by setting Windows 7 Environment Variable "MOZ_FORCE_DISABLE_E10S" to 1.
Prior to Firefox 68 I did it with preference(s) in about:config.
Firstly because I use a single-core single-thread Pentium M, so there would not seem to be much to gain from multi-processing.
Secondly because I fear multi-process Firefox may use more memory - I only have 2GB RAM.

So just now I removed Windows 7 Environment Variable "MOZ_FORCE_DISABLE_E10S" and re-booted, re-enabling multi-process, and now "about:logins" works fine, as you suspected.

This is the first problem I have encountered with single-process Firefox, and AFAIK "about:logins" is the first component in Firefox to absolutely pre-require multi-process. So maybe the time has come to remove Firefox support for Environment Variable "MOZ_FORCE_DISABLE_E10S" altogether, so that multi-process can no longer be forcibly disabled.

Flags: needinfo?(hill-robert)

Hi Bob, thanks for the information. I don't believe we support non-e10s anymore so I will close this bug (see bug 1510087 comment 2).

MOZ_FORCE_DISABLE_E10S is still useful during Firefox development but I agree that it probably shouldn't be available for official release builds.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Priority: P1 → P2
Resolution: --- → WONTFIX

Hi Matthew, Thank you again for so quickly and accurately diagnosing "MOZ_FORCE_DISABLE_E10S" as the cause of my problem - much appreciated!

(In reply to Bob Hill from comment #0)

In order to verify logins/passwords, set "signon.management.overrideURI" to empty, so that "Open menu" ... "Logins and Passwords" opens old-style "Saved Logins" window, which correctly shows all my logins (and passwords).

This solution to the problem should definitely be indicated somewhere in the help.

Because I have the same problem. The about:logins window opens, but even the settings menu does not work there.

Most interestingly, there are no errors in the console ("Inspect item").

So to find out that the case in the disabled e10s is extremely difficult.

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.