Closed Bug 1593690 Opened 3 years ago Closed 3 years ago

Start visited queries from an idle timer.

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Getting visited colors is relatively low priority during page load. GeckoView
was using a 250ms timer, which was somewhat arbitrary.

If this turns out not to be acceptable for desktop, we can change it to a higher
priority timer.

This enables batching queries from the content process. The lesser priority of
the queries, plus the batching that this enables on the content process I hope
will make a dent on the performance regression that bug 1506842 introduces
as-is.

We should probably introduce batching in the other direction too, both of those
are potential follow-up work.

These were unveiled by the coming patch.

We didn't use to call run_next_test for the links that expected no visits before
bug 1591717.

Getting visited colors is relatively low priority during page load. GeckoView
was using a 250ms timer, which was somewhat arbitrary.

If this turns out not to be acceptable for desktop, we can change it to a higher
priority timer.

This enables batching queries from the content process. The lesser priority of
the queries, plus the batching that this enables on the content process I hope
will make a dent on the performance regression that bug 1506842 introduces
as-is.

We should probably introduce batching in the other direction too, both of those
are potential follow-up work.

Duplicate of this bug: 1507857
Assignee: nobody → emilio
Blocks: 1442659
Status: NEW → ASSIGNED
Priority: -- → P2
Blocks: 1593995
Blocks: 1593988

Will land the first part separately to make sheriffs happy and close bug 1593988.

For the second I need to address some minor comments, the third still needs review.

Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/14830ac12439
Fix some races caused by bug 1591717, and add some debugging code. r=mak
Blocks: 1594368
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4bbf56e69f3
Start visited queries from an idle timer. r=mak,lina
https://hg.mozilla.org/integration/autoland/rev/b461f28b9c9e
Batch content -> parent visited queries. r=mak
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.