Closed Bug 1597622 Opened 2 months ago Closed 2 months ago

The Enhanced tracking protection panel is displayed in Kiosk mode after Reconnecting to the internet

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 73
Tracking Status
firefox70 --- disabled
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- verified

People

(Reporter: rares.doghi, Assigned: xeonchen)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image protectkiosk.png

[Affected versions]
Firefox 71.0b10

[Affected platforms]
All

[Steps to reproduce]

  1. Open the Firefox browser in KIOSK mode from the command line using firefox.exe --kiosk https://www.mrmoneymustache.com/2013/02/22/getting-rich-from-zero-to-hero-in-one-blog-post/
  2. Disconnect the device from the internet.
  3. Click the Next POST button from the bottom of the article.
  4. Reconnect to the internet and click the Try Again button.

[Expected result]
The Enhanced Tracking protection panel should not be displayed in kiosk mode.

[Actual result]
The Enhanced Tracking Protection panel is displayed and the user could reach Privacy Settings and General Settings.

Please also note that By Clicking F9 on a keyboard while in Kiosk mode and then Exiting Reader View the Enhanced Tracking Protection panel is also displayed.

Not exactly sure where kiosk bugs are meant to live but it isn't here.

Component: Startup and Profile System → General
Product: Toolkit → Firefox

:mkaply, can you find a home for this?

Flags: needinfo?(mozilla)

I assume you saw the "Nightly stopped a social network from tracking you here" first and then clicked on See Protections?

Flags: needinfo?(mozilla)

Gary:

Can you offer a suggestion on the easiest place to add a check for kiosk mode and not show any of the CFR stuff? I'm guessing something similar to:

https://bugzilla.mozilla.org/show_bug.cgi?id=1589509

I would rather not set a pref as part of kiosk mode, but do an explicit check if possible (BrowserHandler.kiosk)

Flags: needinfo?(xeonchen)

(In reply to Mike Kaply [:mkaply] from comment #4)

Gary:

Can you offer a suggestion on the easiest place to add a check for kiosk mode and not show any of the CFR stuff? I'm guessing something similar to:

https://bugzilla.mozilla.org/show_bug.cgi?id=1589509

I would rather not set a pref as part of kiosk mode, but do an explicit check if possible (BrowserHandler.kiosk)

I presume you don't wanna see celebrating milestone toast introduced in bug 1579974, either.
Then you can skip the observe function if BrowserHandler.kiosk is true.

If the KIOSK mode won't be changed until closing Firefox, maybe you'd like to check BrowserHandler.kiosk here

Flags: needinfo?(xeonchen)
Component: General → Messaging System
Assignee: nobody → andrei.br92
Priority: -- → P1
Assignee: andrei.br92 → xeonchen
Pushed by xeonchen@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/18d988833012
disable ASRouter.triggerHandler under kiosk mode; r=andreio
Keywords: leave-open
Pushed by xeonchen@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8fc8a1f59578
add test for kiosk mode enabled; r=andreio
Keywords: leave-open

Backed out changeset 8fc8a1f59578 (Bug 1597622) for causing eslint failure at browser/components/newtab/test/unit/asrouter/ASRouter.test.js:2560:1.

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=8fc8a1f595788306652351e0971ecaf13880a1fe

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=279535885&repo=autoland&lineNumber=54

Backout link: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=82ae4e73b3baacc7490690c3287c3d2ab13fc7d2

[vcs 2019-12-04T10:26:07.827Z] executing ['hg', 'robustcheckout', '--sharebase', '/builds/worker/checkouts/hg-store', '--purge', '--config', 'hostsecurity.hg.mozilla.org:fingerprints=sha256:17:38:aa:92:0b:84:3e:aa:8e:52:52:e9:4c:2f:98:a9:0e:bf:6c:3e:e9:15:ff:0a:29:80:f7:06:02:5b:e8:48,sha256:8e:ad:f7:6a:eb:44:06:15:ed:f3:e4:69:a6:64:60:37:2d:ff:98:88:37:bf:d7:b8:40:84:01:48:9c:26:ce:d9', '--upstream', 'https://us-west-1.hgmointernal.net/mozilla-unified', '--revision', '8fc8a1f595788306652351e0971ecaf13880a1fe', 'https://us-west-1.hgmointernal.net/integration/autoland', '/builds/worker/checkouts/gecko']
[vcs 2019-12-04T10:26:07.917Z] (using Mercurial 4.8.1)
[vcs 2019-12-04T10:26:07.917Z] ensuring https://us-west-1.hgmointernal.net/integration/autoland@8fc8a1f595788306652351e0971ecaf13880a1fe is available at /builds/worker/checkouts/gecko
[vcs 2019-12-04T10:26:07.918Z] (existing repository shared store: /builds/worker/checkouts/hg-store/8ba995b74e18334ab3707f27e9eb8f4e37ba3d29/.hg)
[vcs 2019-12-04T10:26:08.413Z] (pulling to obtain 8fc8a1f595788306652351e0971ecaf13880a1fe)
[vcs 2019-12-04T10:26:08.681Z] searching for changes
[vcs 2019-12-04T10:26:18.863Z] adding changesets
[vcs 2019-12-04T10:26:18.902Z] 
[vcs 2019-12-04T10:26:18.907Z] changesets [=>                                                          ]  1/27
[vcs 2019-12-04T10:26:18.908Z]                                                                                 
[vcs 2019-12-04T10:26:18.908Z] adding manifests
[vcs 2019-12-04T10:26:19.109Z] adding file changes
[vcs 2019-12-04T10:26:19.792Z] added 27 changesets with 160 changes to 149 files
[vcs 2019-12-04T10:26:20.342Z] new changesets f6b30c89d279:8fc8a1f59578
[vcs 2019-12-04T10:26:20.344Z] (purging working directory)
[vcs 2019-12-04T10:26:31.214Z] 
[vcs 2019-12-04T10:26:31.386Z] updating [>                                                           ]   4/154
[vcs 2019-12-04T10:26:31.393Z]                                                                                 
[vcs 2019-12-04T10:26:31.393Z] 150 files updated, 0 files merged, 4 files removed, 0 files unresolved
[vcs 2019-12-04T10:26:31.607Z] updated to 8fc8a1f595788306652351e0971ecaf13880a1fe
[vcs 2019-12-04T10:26:31.612Z] PERFHERDER_DATA: {"framework": {"name": "vcs"}, "suites": [{"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "pull", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 11.806339025497437}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "purge", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 8.336559057235718}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "update", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 2.9265639781951904}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "overall", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 23.69120216369629}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "overall_pull", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 23.69120216369629}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "overall_pull_fullcheckout", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 23.69120216369629}, {"extraOptions": ["m3.xlarge"], "lowerIsBetter": true, "name": "overall_pull_populatedwdir", "serverUrl": "us-west-1.hgmointernal.net", "shouldAlert": false, "subtests": [], "value": 23.69120216369629}]}
[vcs 2019-12-04T10:26:31.954Z] TinderboxPrint:<a href=https://us-west-1.hgmointernal.net/integration/autoland/rev/8fc8a1f595788306652351e0971ecaf13880a1fe title='Built from autoland revision 8fc8a1f595788306652351e0971ecaf13880a1fe'>8fc8a1f595788306652351e0971ecaf13880a1fe</a>
[setup 2019-12-04T10:26:31.954Z] GECKO_PATH is /builds/worker/checkouts/gecko
[task 2019-12-04T10:26:31.954Z] executing ['bash', '-cx', 'cp -r /build/node_modules_eslint node_modules && ln -s ../tools/lint/eslint/eslint-plugin-mozilla node_modules && ln -s ../tools/lint/eslint/eslint-plugin-spidermonkey-js node_modules && ./mach lint -l eslint -f treeherder --quiet -f json:/builds/worker/mozlint.json\n']in /builds/worker/checkouts/gecko
[task 2019-12-04T10:26:31.958Z] + cp -r /build/node_modules_eslint node_modules
[task 2019-12-04T10:26:33.577Z] + ln -s ../tools/lint/eslint/eslint-plugin-mozilla node_modules
[task 2019-12-04T10:26:33.578Z] + ln -s ../tools/lint/eslint/eslint-plugin-spidermonkey-js node_modules
[task 2019-12-04T10:26:33.579Z] + ./mach lint -l eslint -f treeherder --quiet -f json:/builds/worker/mozlint.json
[task 2019-12-04T10:26:34.621Z] Using base prefix '/usr'
[task 2019-12-04T10:26:34.621Z] New python executable in /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/bin/python3
[task 2019-12-04T10:26:34.621Z] Also creating executable in /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/bin/python
[task 2019-12-04T10:26:37.108Z] Installing setuptools, pip, wheel...done.
[task 2019-12-04T10:26:38.408Z] b"running build_ext\nbuilding 'psutil._psutil_linux' extension\ncreating build\ncreating build/temp.linux-x86_64-3.5\ncreating build/temp.linux-x86_64-3.5/psutil\nx86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=563 -DPSUTIL_LINUX=1 -I/usr/include/python3.5m -I/builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/include/python3.5m -c psutil/_psutil_common.c -o build/temp.linux-x86_64-3.5/psutil/_psutil_common.o\nx86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=563 -DPSUTIL_LINUX=1 -I/usr/include/python3.5m -I/builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/include/python3.5m -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-3.5/psutil/_psutil_posix.o\nx86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=563 -DPSUTIL_LINUX=1 -I/usr/include/python3.5m -I/builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/include/python3.5m -c psutil/_psutil_linux.c -o build/temp.linux-x86_64-3.5/psutil/_psutil_linux.o\ncreating build/lib.linux-x86_64-3.5\ncreating build/lib.linux-x86_64-3.5/psutil\nx86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-Bsymbolic-functions -Wl,-z,relro -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 build/temp.linux-x86_64-3.5/psutil/_psutil_common.o build/temp.linux-x86_64-3.5/psutil/_psutil_posix.o build/temp.linux-x86_64-3.5/psutil/_psutil_linux.o -o build/lib.linux-x86_64-3.5/psutil/_psutil_linux.cpython-35m-x86_64-linux-gnu.so\nbuilding 'psutil._psutil_posix' extension\nx86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=563 -DPSUTIL_LINUX=1 -I/usr/include/python3.5m -I/builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/include/python3.5m -c psutil/_psutil_common.c -o build/temp.linux-x86_64-3.5/psutil/_psutil_common.o\nx86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=563 -DPSUTIL_LINUX=1 -I/usr/include/python3.5m -I/builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/init_py3/include/python3.5m -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-3.5/psutil/_psutil_posix.o\nx86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-Bsymbolic-functions -Wl,-z,relro -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 build/temp.linux-x86_64-3.5/psutil/_psutil_common.o build/temp.linux-x86_64-3.5/psutil/_psutil_posix.o -o build/lib.linux-x86_64-3.5/psutil/_psutil_posix.cpython-35m-x86_64-linux-gnu.so\ncopying build/lib.linux-x86_64-3.5/psutil/_psutil_linux.cpython-35m-x86_64-linux-gnu.so -> psutil\ncopying build/lib.linux-x86_64-3.5/psutil/_psutil_posix.cpython-35m-x86_64-linux-gnu.so -> psutil\n"
[task 2019-12-04T10:26:38.408Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2019-12-04T10:42:35.103Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/browser/components/newtab/test/unit/asrouter/ASRouter.test.js:2560:1 | Delete `⏎` (prettier/prettier)
[taskcluster 2019-12-04 10:42:35.470Z] === Task Finished ===
[taskcluster 2019-12-04 10:42:35.909Z] Unsuccessful task run with exit code: 1 completed in 990.026 seconds
Flags: needinfo?(xeonchen)

I should have linting auto-triggered :(

Flags: needinfo?(xeonchen)
Pushed by xeonchen@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8425a615e599
add test for kiosk mode enabled; r=andreio
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Does this need uplift or can it ride the trains to 73?

I think it can ride the trains unless we get customer feedback.

I have verified that the issue is no longer reproducible on Firefox Nightly 73.0a1 (Buid ID 20191212095326) using Win 10, Mac 10.14 and Linux Debian 9.
The Enhanced Tracking protection panel is not displayed while in KiosK mode.
Note that I was not being able to reproduce the initial issue from other page that the one from the example.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.