Closed Bug 1599949 Opened 1 year ago Closed 1 year ago

macOS 10.15 - New and unread messages not shown in bold

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86_64
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1563948

People

(Reporter: mpstryker, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

Steps to reproduce:

I clicked "Get Messages" and received new emails from a Pop3 server. Similar results when I marked an existing message as Unread. Version 60.9.1 (64-bit) Mac-OS 10.15.1 "Catalina" fully updated.

Actual results:

Email messages in message list were shown in regular font

Expected results:

The new and unread messages should have been rendered in Bold font. Previous MacOS and Thunderbird versions rendered unread messages in message list entries in Bold font.

Same problem here with a new but fully updated Catalina install, was working as expected before the OS upgrade.

I can confirm as well.

OS: Unspecified → macOS
Hardware: Unspecified → x86_64
Summary: New and unread messages not shown in bold → macOS 10.15 - New and unread messages not shown in bold
Component: Untriaged → Folder and Message Lists

This appears to be fixed in 72.0b1.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Fixed in 72.0b1, well, I hope much earlier since we suggested update to TB 68 in bug 1563948.

Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1563948
Version: 6 Branch → 60

In case anyone would like to solve this in version 60.x.x, this can be worked around by modifying the chrome/userChrome.css file in your Thunderbird profile directory (typically located at ~/Library/Thunderbird/Profiles/<something>.default/ on MacOS, or similar on other platforms).

The following snippet works for me

#threadTree treechildren::-moz-tree-cell-text(unread) {
    -moz-appearance: none !important;
    font-family: Arial;
    font-weight: bold;
}

The key part I think is to indicate a font (Arial here), that MacOS will recognize and know how to display in bold. You might need to tweak this depending on your other settings.

Tested on MacOS 10.15.6 (Catalina), Thunderbird 60.9.1.

You need to log in before you can comment on or make changes to this bug.