Closed Bug 1603728 Opened 8 months ago Closed 7 months ago

Deleting pills (e.g. with BACKSPACE or DEL) also deletes focused pill which is not selected

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1602431

People

(Reporter: bugzilla2007, Unassigned)

References

Details

I am looking at trunk with bug 440377: 73.0a1 (2019-12-12) (64-bit).*

Part of the "focus on selection" and "thou shalt not kill" series ;-)

STR

  1. Compose new msg with recipient pills: (pill1)(pill2)(pill3)|
  2. press cursor left key to select pill3 (doesn't select, bug 1602397; so press space bar to select pill3)
  3. hold ctrl while pressing cursor left twice (focus-only on pill1; so only pill3 is selected)
  4. press delete or backspace

Actual result

  • selected-(pill3) AND focus-only-(pill1) both get deleted

Expected result

  • only selected-(pill3) must be deleted
  • don't delete focused pill which is not selected

*: https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=019eaf0f9cf72621a436ce06b2607bc5a3532fae

See Also: → 1602431, 1603563, 1602397

For comparison:

  • in TB attachment pane, select one attachment and focus-only another, press DEL. --> only the selected attachments is deleted, focused item remains focused.
  • in Win Explorer, select one file and focus-only another, press DEL. --> only the selected file is deleted, focused file remains focused.

This wasn't limited to deleting with Backspace and DEL, also seen for context menu and (x) on pills (when we still had that), adjusting summary accordingly.

Summary: Deleting pills with BACKSPACE or DEL also deletes focused pill which is not selected → Deleting pills (e.g. with BACKSPACE or DEL) also deletes focused pill which is not selected

This was a bug in its own right, which I am now fixing in related bug 1602431.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1602431

Mass-changing bugs around the new recipient area (pills) from product/component MailNews Core/Composition to Thunderbird/Message Compose Window, because composition frontend code is not shared with SM. Mostly cloned from Bug 440377 which started out in MailNews Core long back.

20200614001RecipientPillsProductChangeTypeBug

Component: Composition → Message Compose Window
Product: MailNews Core → Thunderbird
You need to log in before you can comment on or make changes to this bug.