Closed Bug 1604452 Opened 3 years ago Closed 3 years ago

Password change modal is displayed in Private Browsing after changing initial password with a saved, edited, generated one

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1604472
Tracking Status
firefox71 --- disabled
firefox72 --- fixed
firefox73 --- fixed

People

(Reporter: tbabos, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:generation])

Attachments

(3 files)

Attached file Log.txt

Affected versions
Nightly 73
Beta 72

Affected platforms
Windows 10 x64 (to be checked on the other OS)

Steps to reproduce

  • Launch Firefox and use Private Browsing window
  • Go to reddit.com
  • Log in with valid credentials
  • Reach the change password form
  • Generate a new secure password, edit it and exit form
  • Re-open form, fill in the old password with the valid account password
  • Fill in the "New Password" field with the generated password via Context Menu -> Use Securely generated password
  • Edit the filled in generated password once more
  • Click out of the field
  • Toggle the autocomplete dropdown for the "Confirm New Password" and choose the "No username" entry
  • Click on Save/Change button on the form

Expected result
There should be no password change modal displayed, like in normal browsing mode. The dismissed doorhanger should have the blue key icon and the username for the generated password can be added and saved there.

Actual Result
The "Confirm Password Change" modal is displayed.
The dismissed doorhanger with the blue key is also displayed.
Confirming the changes in the password modal will not dismiss the blue key.

Note
This is happening only in Private Browsing mode.
Attached screen recording of private browsing behavior, normal browsing behavior and Log export of the issue.

Summary: Password change modal is displayed in Private Browsing after changing initial password with a saved, generated one → Password change modal is displayed in Private Browsing after changing initial password with a saved, edited, generated one

Thanks for the report. We will investigate.

Priority: -- → P2
See Also: → 1154763

This seems to be the same underlying issue as bug Bug 1604472, and I just walked through the STR with & without that patch applied and it looks good so I'm going to dupe it. :tababos, once the patch on there is merged and resolved, can you confirm these STR are also fixed?

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(tbabos)
Resolution: --- → DUPLICATE
Duplicate of bug: 1604472

Yes, that patch also fixed this issue. Thanks!

Flags: needinfo?(tbabos)
You need to log in before you can comment on or make changes to this bug.